Smart Controller Not Syncing with Mission Hub

Just got a new smart controller. Installed Litchi from Amazon apps. Launched OK. Logged in to my Litchi account. Pretest fly today and missions didn’t download from hub. No previously saved missions available.
Logged out and in again still no joy.
Just remembered the only thing changed today was installed an sdcard which changed some storage location. Probably not related but worth mentioning.

Resolved :slight_smile:
Uninstalled from Amazon apps then re-installed.
Opened Litchi, logged in and voila my missions were downloaded from the hub :slight_smile:

1 Like

Logging out then in again within Litchi on your smart device will sometimes also fix this.

I ran into the same problem with my Crystal Sky yesterday.
Instead of reinstalling Litchi, I Force Closed it in Settings, then rebooted the CS.
Opened Litchi and had to log in again, but the onscreen keyboard wouldn’t show up. Closed Litchi and opened the browser to type an internet search, NO keyboard.
Then instead of rebooting the CS I shut it off and on again.

Everything works as it should now !