Slow mission speed between waypoints

Why is the drone flying so slow when flying a mission ? i set the speeds in the flyhub both to max but between waypoints the max speed the drone flies still is 10 km/h forward and 2-3km/h up and down ?

it would sped it up a lot if the drone would at least fly 30km/h betwwen the waypoints.

Best

Disable obstacle avoidance

1 Like

What drone and how far between the waypoints

1 Like

Are you setting the “Max Flight Speed” appropriately?

Capture

1 Like

yeah those where set to 54 but didn’t set the speed on each waypoint to 54 also, no i found it. thanks for your help and suggestions anyway!

If you want the drone to fly at a constant speed for the duration of the mission you only need to set the “Cruising Speed” in the “Settings” dialog. Then, leave the speed slider for each waypoint all the way to the left which will cause the drone to use that cruising speed.

Capture

2 Likes

i had the mission pre planned with ancient.land . And i guess i forgot to set the speed properly here. So i had to reset the speed on all waypoints.