Signal breaks for a moment, couses mission to stop, how to auto-continue?

I’m still learning Litchi. On Mini 2. My problem is that the connection to aircraft seems to quite easily break for a moment, and if I’m running an orbit-mission or some other automation, the connection break halts the mission. Is there a way to keep Litchi running the mission, as the connection always re-establishes in only seconds? Some setting for tolerance so the mission would keep running / auto-continuing as soon as the connection re-establishes?

Also, is it the only way to (re-)start orbit mission by opening the poi settings and start from there? It’s very inconvenient to go thru that if you need to restart it repeatedly.

I’m not sure why the connection has been so unreliable recently, even with the drone quite close by, tho it’s been as cold here as -30’C so might it have something to do with it.

On the Mini 2 (and other VSC drones), all of the aircraft movements are controlled by signals sent from the controller (Virtual Stick Commands). There is no tolerance setting.
So if the controller/drone signal is interrupted, the aircraft has to wait and establish a controller signal or hover or land (depending on how you set the Signal Lost Behavior.

Read this helpful information compiled by one of our major forum contributors.

Yes I know it’s done with virtual stick movements, it’s not about that I’m asking. Is it the normal function in Litchi that if the connection very briefly breaks but almost immediately re-establish, the mission that was running is stopped and you have to manually restart it? And with orbit-function, you need to access to the poi settings every time to re-active the orbit? Or is the mission supposed to carry on as soon as the connection re-establishes, which happens in my case in 1-3 seconds from the break.

It is my understanding that the control signal is monitored about every 1/10 second.

That, I do not know.

If the signal is lost, then yes, you would have to restart the mission. However, a mission is something different from an orbit. If you were flying a waypoint mission, you could restart the mission and specify the starting waypoint. However, if you were flying an orbit (which is not a waypoint mission), you have to start by specifying the POI.

What I would try to troubleshoot is why you are loosing connection. The main reasons for loosing the connection between the drone and controller are:

  1. Too great a distance between the drone and controller.
  2. Trees or obstacles between the drone and controller.
  3. Interference from Wi-Fi and other telecommunication signals in the area.

Do any of those three things seem like they might have something to do with your flying location?

Okay, so I was afraid that this is normal function in signal break. I would really hope there was a setting for tolerance, so that Litchi would carry on the with the mission, if the signal re-establishes in a few seconds :frowning: Or even a simple way to manually tell litchi to carry on the mission from the very point it is at. Too bad.

Yes I’m aware of the those realities about signal interference. The drone has been quite close (50-200m) and sometimes some trees in between, sometimes nothing in between, sometimes maybe I have turned around a bit to wrong direction, but it should have not broke the signal since drone has been so close by. Compared to how good the signal has been before (I’ve flown my Mini 2 since May 2023). As mentioned it HAS been rather cold here recently (-30’C or -22’F), so it’s the only thing I can suspect to have something to do with the signal breaks…

If you use Airdata as your flight log repository, it would be helpful to share a flight log from one of the failed missions.
Signal strength is not going to be affected by temperature. One or more of the items that Wes mentioned are likely causing the interference.
If the aircraft is at a low altitude, there might be numerous things between the controller/drone straight line. Yes, even turning away can affect signal strength.

It is a normal condition that exists in VSC drones, not Litchi.

Sharing flight logs will be very helpful.

Yes I know turning around can and will affect the signal, but I would have thought it wouldn’t affect so much that the connection fully breaks, even briefly, when drone is rather nearby. For me it seems clear it shouldn’t break that way, otherwise other users with VSC drones would encounter the problem too and it would be more discussed etc. It almost renders autonomous functions unusable. With automatic mission restart, it still would be usable, but no option for that in Litchi. Or even a single tap manual mission restart would do. Say, having it bound to custom button on aircraft. That way no need to take gloves off to use the phones’ touchscreen. And the signal has broken a few times even when my controller is pretty much aimed at the aircraft, with nothing in between and at a distance less than 100m. So something must not be right. Still, it’s not too long ago when I was flying 2km away, so connection has been working like it should, until recently. And only recently it has been this cold. (I have only recently started using Litchi, so my experiences with it are still limited)

I’m all aware about the things that cause signal weakening, and concidering my past experiences with this very same drone, I find these signal breaks I have encountered recently are something that didn’t used to happen.

Someone on reddit answered “When I had my mini 2, I noticed if the controllers antennaes were pushed on slightly or if the cable was shifted, the controller would lose connection temporarily. At first I thought my cable had a break somewhere but I didn’t have issues once I fidget the controller around a bit.” So I’m now wondering if there’s something like that with my controller too.

Also, litchi reported “camera not connected” a couple of times recently, and the video preview was stuck for a moment. After a few seconds, back to normal again. And also some weird glitching in the preview time to time. So it has led me wondering if the very cold temps have somehow affected my equipment after all.

Nevertheless, I don’t find a reason why not to include automatic mission restarting -option in Litchi, since it would be very helpfull in anycase.

I haven’t been using Airdata.

One thing comes to my mind tho. When flying the last time, I was using my old android phone to listen to music thru bluetooth headphones. And my main phone (the one that’s used in the RC), might have had the wifi access point enabled and the other android phone might have been connected to that access point. Not sure about the latter tho, but at least the other phone was playing music thru bluetooth to my headphones. Could active bluetooth connection cause those signal issues? Or if the wifi access point was active?

Neither of those would be the culprit.
I think Slup (on another forum) gave the most pertinent reply. You’re running under CE rules which limit transmission power.

Does this make you think there’s something else going on other than just “normal” signal interference?
“Also, litchi reported “camera not connected” a couple of times recently, and the video preview was stuck for a moment. After a few seconds, back to normal again. And also some weird glitching in the preview time to time. So it has led me wondering if the very cold temps have somehow affected my equipment after all.”

I meant normal condition to mission not to continue after signal re-establishes. Of course mission to stop working for the time the signal is lost, happens to all VSC drones. It just seems so weird to me that there’s no way to make it continue without fiddling the app again and again.

No, not at all.
Sharing a flight log will help clarify things, if you are willing to do so.

More evidence of lost signal.

Again … temperature is not a factor.

Here is more info from the Litchi Help website:

  • Signal Lost Behavior: This defines the behavior of the aircraft if signal is lost; choose between “Hover”, “Landing” or “Return To Home”.
  • Exit Waypoint Mission on Signal Loss: When enabled, waypoint missions will end when signal is lost. When that happens, the drone will then execute the failsafe procedure (which can be changed with the “Signal Lost Behavior” setting). This setting cannot be changed for newer DJI drones (Mavic Mini 1, Mini 2, Mini SE, Mavic Air 2 and Air 2S) as they are not able to continue waypoint missions beyond signal range.

Thanks for all your replies. I’m eager to know, how does cold temperature not be a possible cause for the devices to malfunction? I know the signal will carry on as well in cold or hot, but if the device sending or receiving the signal somehow manages to malfunction because of extreme cold, then the cold temp could be the reason for weird behaviour, or can it not? I’m not saying it IS the reason in this case, but you seem to be surprisingly sure the cold temp has nothing to do with my issue.

I haven’t examined any logs ever before, so I first need to look in to that, so I can share it.

I just thought the “camera not connected” could point towards some other issue with drone, specifically the camera, other than signal issues. Maybe I was wrong then.

Yes I had read the info from Litchi help, about signal lost behaviour. But it does seem to only concider situations where signal is REALLY lost, meaning it’s not lost only briefly as in my case. Same as with dji fly app; the RTH won’t kick in from brief signal breaks, but only after the signal is lost for a certain period of time. The same way I would have supposed Litchi would continue with the mission as soon as the signal re-establishes again. Taken, the signal break is only brief, and signal level is good after re-establishing.

I had the same issue once with a phantom v2… Constant signal lost. Turned out I had a damaged antenna wire from a :hard landing" . I had the landing gear / antenna replaced and issue went away.

1 Like

AirData will provide you with a lot of information including a “Signal Score Map” which shows the signal strength throughout the course of the mission. Here is an example:


I’m surprised you are having this much trouble with the signal between the drone and your controller. Which software you are using should not impact the signal between your controller and your drone. However, you may have different settings in Litchi vs DJI Fly. Here are some things to check in Litchi’s settings:

  • Ocusync Preview Quality: For Ocusync-based drones only. Select the channel bandwidth between 10MHz and 20MHz or Auto. On Auto, both the channel and preview quality will be selected automatically.
  • Ocusync Transmission Channel: For Ocusync-based drones only. Select a transmission channel or Auto. On Auto, both the channel and preview quality will be selected automatically.

Also, the signal from your controller is directional. The signal does not travel equally in all directions. I don’t remember if you are holding your controller (RC-N1?) or placing it in a pocket or something. It should be held so that the antennas are facing the drone.

The temperature should not affect signal strength. I have read about people flying in temperatures you describe and they haven’t mentioned loosing signal.

I just registered on Airdata, but my logs are larger than the 15MB free limit. I also installed FRAP, but it didn’t show any files in the folder I pointed it to look for my .csv. Will have to look into it with more time.

I’m aware of the directionality of the antennas, that you should point antennas towards the drone. My use case often includes myself walking or skiing, and recording myself from different angles etc. I’m carrying the RC in a belly-pocket belt, it sits conveniently there for easy access and observation. Therefore the antennas inevitably occasionally point other directions than the drone. So I’m not super surprised for the connection to break, but it has recently happened also with the antennas pointed at the drone. Anyways, the drone is usually so close to me/RC, that the signal strenght is good, except the occasional brief breaks. For this reason an auto-resume -option after signal re-establishment would be a great feat.

I did just find out you can bind pause/resume flight to a custom button on controller. I’m yet to try it so I don’t know if the button will also initially start the mission, and would it be helpful in my case. If it’s still necessary to actually start the mission thru litchi app on phone screen, it won’t help here. Because that’s what needs to be done after the signal break, as litchi stops the mission (is it different than “pause” and is “resume” different than actual start?) Anyways, still an auto-resume would be a great option to have.

My biggest Litchi flight log (just over 23 minutes) is 6.1MB. I use an iPad as my flying device.
What flight device are you using? Android? iOS? Smart screen?

Are you using Follow mode, or Orbit? It sounds like you are not using a pre-planned Litchi Mission with waypoints nor an Orbit session if you are walking or skiiing.
If you are using Follow, there is a Warning on the Litchi Help site:
Warning It is advisable to only use the Follow feature in wide open areas.

I’m on android. I was wondering why the logs are so large. EDIT: There’s 3 logs for 3 runs. My runs totalled around 35min and the log files total at around 155MB.

I’ve used orbit, follow and track -functions. For example, set orbit center to 100m away, start orbit and ski thru the center point etc to have drone circle around my way.

I have yet to try pre-planned missions, but will try out soon so to get hold of it all.

Those functions rely on a strong steady signal, since all of the processing is done in the flying device (your Android device).

The Litchi flight logs usually start when the motors start and end when motors are stopped.
They should be named similar to this … 2023-03-19_12-10-15_v2.csv