Saving new missions from hub not working

Good day,

I create several missions before with no problem. I tried saving a new mission today with no luck. When clicking save, nothing happens. I can create and edit new missions but cannot save any new missions. Tried in another browser, same problem. Can anyone help?
Many thanks.

1 Like

I am actually glad to see that another Litchi user is experiencing the same inability to save newly created flights that I encountered. While the exact cause of this anomaly is open to speculation, the good news is that the problem goes away after a few days.

Over the past week, I lost several highly detailed flight plans I drew up but simply could not save, only for the problem to resolve itself whereby I am once again able to save new Litchi missions. So, without having the foggiest idea why Litchi goes offline now and then, I can assure you that normalcy typically resumes within 3 days.

Create a test mission on your mobile device.
Make sure the mobile device is connected to the same (home) network and the internet.
Can you save this mission ?