Requirements not F mode

When one wants to start a waypoint mission and the error 'Requirements not met…select F mode" comes up, it’s confusing for owners of newer drones.
Newer drones have no F mode, only C, N & S mode.
Change the message to “… select N or F mode”.

1 Like

And for old drones, there are no c, n and s modes.

Drones with C mode: ALL (used to be called Tripod Mode)
Drones with N mode: ALL (used to be called P mode)
Drones with S mode: ALL
Besides that, What’s your point?

Which Litchi version did you use to see that error?
We did change the error message not long ago and it should not mention F for new drones

My remote only has a “sport” switch, I don’t have any others. I also have no complaints about the litchi about the name of the operating mode.

In response to the topic “I need Help With my Mini2 and Litchi App for IOS” I took my old iPad Mini 4 and connected it to the DJI mini placed in Cine-Mode. Loaded a mission and hit the GO button. Then the above message was displayed.
I didn’t realize I still had an older version of Litchi installed (v2.10.1).

Hello I am using the latest version on Magic 2 Pro everything works fine in US but the Litchi app WP, Orbit none worked in Europe tried in Turkey same message Requirements Not Met, Italy same issue, France, Portugal and Switzerland same thing. This was a commercial shoot very disappointed promised myself never use your crappy application, and no doubt will post a You Tube how Litchi App almost made me lose a major client in Europe.

Lots of people use Litchi in Europe. I live in the USA but have used Litchi with a Mavic 2 in Europe a few years ago. Did you have your controller in “N” (Normal) mode? If so, there must be something different about your drone or flying device. If you want to find out why it wasn’t working, please share more details about your drone (firmware version) and flying device (IOS or Android, Litchi version).

Barris hi, I have multiple Drones and the one I use Litchi exclusively for Mavic Pro 2 since no SDK support for Mavic 3 Cine as yet. The Drone was on P constantly but I tried Cinematic, never S. Even today here in Milano The was able to compile mission on the Hub, but when I went to the site right across from Milano Centrale to do a high elevation picture and orbit for KPMG Towers, same problem happened.

I don’t know if I can check any logs why the app just refuses to function. I prefer Litchi for mapping and way points but I guess it’s reliability is very questionable. Let me know what you think I should check.

Craft is Mavic Pro 2 Litchi App version is 2.14.3

One more thing I am using iOS version 16.5.01 on iPhone 12

That switch, “C P or S” is the one that most often results in that message when not set to P (or N). Your software appears to be up-to-date.

The message “Requirements not met” is coming from DJI’s MSDK. The SDK is passing that message to LItchi and Litchi is displaying it on the screen. Unfortunately, the error messages from DJI’s MSDK are not always very descriptive. This message simply means that some setting is not set appropriately for waypoint missions.

Other things that have been known to cause that message to appear are actually in the DJI Go4 app. Run Go4 and make sure that:

  • “Multiple Flight Modes” is on
  • “Beginner Mode” is off

After doing that, stop Go4 and try Litchi again.

Thanks, I am sure actually certain I have beginner mode off. I have the intelligent mode on since I am now using DJI Go 4 app Waypoint 2.0. I don’t see any error messages on Go 4app I usually start of with DJI app first to set my Home Location set, then launch Litchi app. I will try again making sure no error conditions reported by Go 4 App. BTW- Thanks for your help. I did my last city coverage this morning in Milano. Now heading back to Los Angeles.