Remove the altitude limit for waypoint flights for SAR and tower inspections etc

There are times when flying higher than 400 feet above the takeoff point is perfectly legal, such as tower + building inspections, or flying up mountains. Whether you have unlocked the altitude yourself, or got it via DJI for SAR flights, being able to program a search area that takes you beyond the arbitrary 1,640 feet that DJI sets, or fly an orbit flight to higher altitudes would be great!

That is not something we can do, the limit is enforced in the DJI firmware

1 Like

You can look into drone-hacks.com

Already hacked, but you can’t create waypoint missions that go higher than 1640 feet (500meters) above the take off location.

1 Like

Oh yea, forgot about that. Sorry

I am already past the DJI firmware limitations, I mean being able to program a waypoint flight that can be set higher than the 1,640 feet above take off point. If you do that now, and have it set at a specific height above the ground, it stops showing the height above the take off point at 1,640 feet. Maybe it would keep the correct height above the ground, but I’ll have to try it where I have a robust signal so I can stop it if need be. It is possible to confirm it out in the open, but I never would go that high above something in the open. I am usually 50 or 100 feet about the treetops when going up a mountain.

Using NLD I’ve removed the altitude limit for my Mavic Pro 1 but when I try to launch the drone on a flight I created to send the drone into a spiraling ascent from takeoff to 1,000 feet AGL, I get a Litchi warning that terminates the mission with an error message stating that the drone cannot fly higher than 120 meters, or about 360 feet AGL.

Went to Litchi’s settings page, and tried to change the maximum altitude from 120 meters to 400 meters, but my entry was ignored as the maximum altitude defaulted back to 120 meters.

Residing way out in the boondocks where the only air traffic is at 20,000 feet and above, and where there are no drone laws, I planned this waypoint mission to record footage of my humble abode by making it a Point of Interest at the center of the drone’s spiraling ascent up to 1,000 feet and then back down, but this altitude limit just refuses to die like Dracula.

Any thoughts on how to drive a final stake through the heart of this dastardly altitude restriction I am battling here would be appreciated. My NLD mod sheet does show the altitude restriction as being “removed”, but that is not the case. A 120-meter altitude cap is still in effect in Litchi, and evidently cannot be modified by mere mortals.

No, it doesn’t work. I have several missions of 200 meters

If I understand you right, Paxxa, you are saying that the 120-meter altitude cap in Litchi overrides the altitude limit removal that I carried out for this drone with NLD?

You mentioned a mission altitude of 200 meters or 600 feet that your drone successfully flew, and this got me to wondering how it could then be that Litchi imposes a 120 meter or 360 feet AGL altitude limit on my Mavic Pro1 despite my purchase of an NLD license to remove said altitude leash. Hmm the plot thickens.

Perhaps you made a mistake somewhere in the settings.
I did not hack anything, I just set the maximum height of 250 meters in the litchi settings, and 190, 200, 210 meters in the mission and successfully made several hyperlapses like this.

1 Like

I was more confused by the fact that litchi takes a very long time to take off and land in a mission. There is little time left for hyperlapse. I chose the path to take off at 190 meters and launch the mission like this.

Now that is really odd. The altitude limit showing on my Litchi settings screen is 120 meters, and it reverts back to that figure of 120 meters regardless of how many times I try to change that altitude limit to 400 meters.

In other words, Litchi appears to be insisting that I can assign any maximum altitude I want PROVIDED THAT the drone never flies any higher than that sacrosanct figure of 120 meters that is carved in stone. I hope I can find a way to resolve this impasse. I was really looking forward to flying the Mavic Pro up and down the 1,000-foot altitude “spiral staircase” trajectory I plotted out. It was precisely for this sort of mission that I bought an NLD license for each of my two Mavic Pro drones.

Maybe get in touch with the NLD folk & tell them their product isn’t doing what you purchased it for

I just opened a gripe ticket with NLD, so I’m keeping my fingers crossed for some good news before the day is up. I applied the NLD modifications over a month ago, but didn’t get around to testing the altitude limit until just this morning.

1 Like

As is usually the case, the answer to my question about how to remove altitude limits while flying Litchi waypoint missions, was right under my nose all along. Having used No Limit Drones to remove My Mavic Pro’s altitude restriction, I didn’t initially realize that I would also need to go into the settings page of BOTH Litchi AND DJI Go4, to reset the altitude limit to the maximum 500 meters allowable by DJI Go.

In my first bumbling attempt to send my Mavic Pro up a spiraling ascent to 1,000 feet along a Lichi flight path, I tried several times in Litchi’s settings page to increase the maximum altitude above the 120-meter (360 feet) maximum altitude that seemed to be Litchi’s unchangeable default value. Every time I tried to reset the maximum altitude to a higher value, Litchi reverted it back to 120 meters.

Finally, in exasperation, I checked the maximum height shown on DJI Go4’s settings page and found it set to 100 meters (300 feet), out of a maximum possible altitude of 500 meters (1,500 feet). I then upped the maximum allowable altitude limit to 500 meters before closing DJI Go4 and opening Litchi. Checked Litchi’s altitude figure, and lo and behold it had changed to the entry of 500 meters that I made in DJI Go a moment earlier.

Finally, I retried the Litchi waypoint plan I’d created that flew up to 1,000 feet in a spiral ascent. Tapped the “play” button and the Mavic Pro took off to fly the entire 22-minute mission without a glitch. Unlike my typical Litchi flights that fly well beyond the controller’s signal range, this flight path never took the drone any further than 1,000 feet from the takeoff point, allowing me to watch the entire flight and make adjustments to the camera’s downward angle.

So to anyone else who has attempted to remove their DJI drone’s altitude limit by purchasing a No Limit Dronez (NLD) license, be advised that you will STILL need to use DJI Go to set the maximum altitude to 500 meters or 1,500 feet, in order for the NLD hack to succeed in flying the drone above the default maximum altitude of 360 feet.

NLD never got around to replying to my inquiry on this matter, so I decided to share my trial-and-error path to success here for the benefit of anyone else seeking to fly their DJI drone higher than 400 feet where it is legal to do so. I guess the moral of this story is that even if DJI Go4 is never used, it still lurks in the background like a mugger in a dark alley cackling with glee and imposing performance limits on drones until it is explicitly overridden by user input.

This is really funny, good luck with your flights

Drones fly 500 meters without hacking from dronehack

I wondered about that. Oh well, at least I got NFZ removal with the NLD hack, even if the altitude limit removal is not really what the name suggests. All my flights thus far have been at 150 feet AGL so I never bothered to shoot for an altitude record until it I suddenly developed a compulsion to try greater heights just the other day.

Over here in the UK we’re restricted to a max of 400 ft AGL so I have my max height set at 396, which gives a bit off room for any error😂