Problems with live video feed on recent Android app versions

I have been experiencing glitches and stutters in the live video feed on one of my phones. I think this only started occurring on the last couple of Litchi updates. I am currently using Litchi v4.26.7-g on both my phones. My older phone (Moto G4 Plus) runs Android 7, and my newer phone (Samsung Galaxy M31) runs Android 12. The problem only seems to occur on the older phone, but it didn’t used to happen and DJI Go 4 video feed works fine on both. I prefer to use the older phone as the new one is very awkward with the clamping arrangement on the Mavic Pro controller. I would like to be able to go back to an older version of Litchi, to see if I can make the problem go away. I am pretty convinced that it was working okay with Litchi v4.26.4-g. Is there a way of being able to install old versions to try? Any help would be much appreciated. Thanks.

Do you FORCE CLOSE DJI GO4 before running Litchi ?

Most live video feed problems occur when any DJI app is still running in the background.

Thanks for replying. Yes I do always Force Close DJI Go 4 before using Litchi, and I’ve also tried Litchi with DJI Go 4 uninstalled. The problem is still the same. Also tried a clean install of Litchi. Still the same. Are older versions available somehow?

Contact Litchi at support@flylitchi.com

I tried contacting them some days ago using their web contact form, but no reply yet. I’ll try again via email in a couple of days. Thanks.