Problem with Google Earth

When I plan a mission in GE and import into mission hum or from GE desktop to GE online, the waypoints mover around. Some waypoints are where they are supposed to be and other move up to 100 feet. It is not a shifting issue. It has worked perfect in the past. Has something changed? Is it a setting problem?

Another problem is occasionally I get a parser error when importing into mission hub from GE.

I have cleared cookies, reinstalled GE with no change.

Any thoughts? Thanks

I have just tried this and it is working for me. Just to be clear, are you doing the following?

  1. Save a number of “Placemarks” in Google Earth Pro where each Placemark represents the desired view at a waypoint.
  2. Save those Placemarks as a kml file.
  3. Import the kml file into Litchi and have the “Treat Views as Waypoints” checkbox checked.

If these are not the steps you are using, please provide more detail.

1 Like

I did it the exact same way you described. I have tried this on several computers with the same problem. I have posted the problem to GE forum. I have to believe this is an easy fix but what the heck could it be?? Thanks

Would you be willing to share your kml file?

1 Like

I would be glad to share a file. Thanks to GE forum, a suggestion was made to make sure I import and export in the 3D to 3D or 2D to 2D view. The moving waypoints seemed to be a problem when I placed waypoints when I was vertical in GE. As soon as I put a slight angle in my view, then added placemarks, the file worked perfectly when I moved the file between GE and GE online. That is a great start. Unfortunately, when I import the file into Litchi, the waypoints move.

Another suggestion was am I using the same coordinate system between GE and Litchi. Since I messed with many settings, I could have made such a change.

Could you tell me what coordinate system I should use in GE for Litchi? Also, is there a way to change the coordinate system in Litchi?


I give up. Could you please tell me how to upload a file? Thanks,

You can paste the contents of the xml file into a private message and send it to me.

Hi Bill,

I have had a look at the kml file that you sent to me. I see what the problem is. I do not think that there is anything wrong with your settings. Instead, I think all that you need is a better understanding of how the kml import works in Litchi. Let me explain.

A kml file containing placemarks saved from Google Earth Pro contains the coordinates of those placemarks plus the heading, tilt (gimbal pitch angle), and range from the viewing location (sometimes called the “eye of the observer” or “camera location”).

When importing this file into Litchi, you have two choices:

  • Treat Views as Waypoints (checked)
  • Treat Views as Waypoints (not checked)

If you leave that checkbox unchecked, Litchi will simply take your Google Earth placemark coordinates and convert them directory to waypoint coordinates. I think this is what you are expecting.

If you do check that checkbox, Litchi will use all of the information in the kml file to compute waypoint locations that will result in the same views (camera position: height, gimbal pitch angle, heading) to look at those placemarks that you defined in Google Earth. This way, you can design a mission using views from Google Earth instead of waypoint locations and viewing angles.

To make this process work the way you expected it to, you would not want to check that “Treat Views as Waypoints” checkbox. However, if all you want is position placemarks on a map, it would be much simpler to do that directly in Litchi’s Mission Hub.

Here is the view you defined for placemark #4:

When checking the “Treat Views as Waypoints” checkbox, Litchi will compute waypoint #4 (with heading and gimbal pitch angle) to reproduce this view as defined in your kml file. In this case, the coordinates of Litchi’s waypoint #4 obviously cannot be the same coordinates of the placemark #4 that can be seen in this view.

I hope this makes sense.

1 Like

Hi Wes,

I tried one KML file without checking the “Treat View as Waypoints” box and it fixed my problem.

I could do this mission planning in ArcGIS but GE is so much faster. Here is a possible suggestion for Litchi. I am flight planning roads and trails that are mostly covered by forest. I have an overlay in GE to know exactly where the trails are. That is why I need the waypoints in an exact position. If I tried to plan just in Mission Hub, all I see is forest. I don’t believe I can change the date of the satellite image like you can in GE to a no leaf view. I would still need an overlay to see the trails that are hard to see without leaves. I don’t see a way to add an overlay.

I have only used forums a few times with limited success. Wes, you did a great job of problem solving. I really appreciate it. Thanks again, Bill

1 Like

I understand. That makes sense.

Hi Friends, I had a problem that changed my heights and I solved it like this, with that Google Earth repair tool… greetings