Phantom 4 Pro doesn't work with Litchi

I’m pretty sure I’ve got an old P4Pro (I think not V2/V2+) that I’m trying to get working with Litchi for waypoints missions.

I’ve got an up to date Litchi app on an Iphone that I’m using, I’ve managed to re-update the firmware on the drone via the DJI Assistant 2 app (although it claimed it had the latest firmware). I think the RC controller has the latest firmware (the DJI app won’t let me update it).

The Litchi app will connect and let me fly the drone around but pressing play gives me the message about how it needs to be in f-mode or p-mode. Well this drone only has p-mode, and it is in p-mode. I can flip the switch to sport or atti and see the litchi app itself notice the change in the banner at the top of the app. So flip it back to p-mode and get GPS in the banner (and i’ve got satellites and all that) and then still when I press play I get the message about uploading waypoints failed because the drone isn’t in f-mode/p-mode.

Anyone got any ideas?

Drone firmware is 02.00.0810, RC firmware is 1.9.3, DJI app is 4.3.60, Litchi app is 2.15.3, flight controller version is The Litchi app itself reports “N/A” for the RC version, which might be a clue.

The error is:

Upload Failed: Cannot execute in the current mode. For products and flight controller firmware versions that support ‘F’ mode (…), please make sure the remote controller’s mode switch is in ‘F’ mode. For the others, please make sure the remote controller’s mode switch is in ‘P’ mode (code:-5000).

Also I have Mutliple Flight Modes enabled and Beginner Mode disabled.

According to your firmware versions, you have a standard P4 (NOT Pro), and your drone & RC are up to date.

You can download all available documentation and software here:
P4 Download page:

Uploading a waypoint mission should work in P-mode.

Possible reasons it doesn’t I can think of are:
-DJI GO4 is still running in the background.
-There’s something wrong with the waypoint mission. Try a simple 2 waypoints mission close to the take off location.
-Try restarting the drone, RC (in P-mode) and iOS device, then run Litchi only (NO GO4).
-There are/used to be some problems with iOS devices equiped with an USB-C port. Search this forum for “iPad” and/or “iPad mini 6”

I’ve been doing most of that. What I just tried was a factory reset of the drone via the Assistant app, plus a re-re-reflash of the firmware. I also tried to reset the controller, but I found conflicting information on the web about how to do that, I did the C1+C2+record+camera dial but never got a blue flash and tried C1+C2+record alone. Then I also uninstalled (and wiped the data) for DJI GO 4 and Litchi and reinstalled. I had to reenable multiple flight modes, but curiously didn’t have to disable beginner mode which makes me wonder if the controller reset wasn’t successful.

I wound up rebooting the iPhone (it is a lightning-connector, not USB-C) to make sure DJI GO wasn’t running but it still wouldn’t work.

I’ve been just drawing two simple default waypoints on the map using the app and not trying anything clever for a mission for awhile now.

I had been previously telling DJI GO that I had a Phantom 4 Pro mistakenly, but I didn’t repeat that mistake this time (thanks).

The drone is already in the air flying. Put it on the ground and turn off the motors, then start a mission.

Yeah, I was trying to start it in the air, but I just tried it on the ground several times with motors running or not and got the same message.

If the drone is on the ground with motors running, you won’t be able to start a Litchi Mission. The drone either has to be on the ground without motors running, or in the air already (obviously with motors running).

Yeah I’ve mostly tried launching litchi with the drone already flying, I tried it grounded with motors off and that didn’t work either.

I think the P4 may just not be supported any more…

I went and tried dronelink and I’m getting the exact same error message, but also get a “DJI Activation: not supported” message which leads me to this forum post there: