P3A controller problem. Beeping sound from contoller

After a problem with the aircraft control on take off and a hard landing I finally managed to cut of the motors. I was holding the drone by the skids and killed the motors with the left stick. Both sticks were stuck in the down position. Towards me. I clicked them back to the center position. Now when I try to fly the controller emits a beeping sound. Motors start and I have camera control but I can’t get the controller to stop beeping. Can I calibrate the sticks in the Litchi app? Why did the sticks get stuck fully back in the first place? I’ve been flying the P3A for years and have never run across this.

You may need to run DJI Go and see if it shows an error while the controller is beeping.

No, this must be done with the DJI app.

Unless I am misunderstanding, that sounds like a hardware issue if the two stick got stuck. Do they freely move now? Just by moving them around do any get stuck?

The sticks are moving freely now in all directions. I’ll try the DJI app. I preferred the Litchi app since the DJI app got complicated with registering and some problems with going thru several steps when I wanted to fly. It’s been a while since I tried it. It’s strange that the sticks got stuck since the controller was never out of my hands. The P3A barely touched the ground and nicked the props a bit and one skid was forced sideways, I grapped it by a skid and held it while I tried to shut downs the motors. I was going to try to pull the battery but it finally shut down with the left stick pulled straight back. I have another controller and might try pairing it first. I’ll just have to read up on how to do that. :roll_eyes: Thanks for the reply.