Orientation not on POI when flying Mission Hub virtual mission in desktop Google Earth

I’m new to Litchi, but I believe my settings are correct to have the drone focus on a POI. However, despite having settings set as Heading Mode = Custom (WD), Default Gimbal Pitch Mode = Focus POI, and POI number selected in waypoints, when I fly the 3D path in Google Earth, the view simply follows the forward flight path. This also happens if I select someone else’s published mission that focuses on POIs. I’m using the latest Google Earth, exporting KML 3D path from Mission Hub. Frustrated, please help. Thanks!

The easiest way is to install Virtual Litchi Mission V2.8.2
Then click on the globe

Or using Chrome with the extension ‘Chrome Litchi Virtual Mission’ then Export as VLM

Thank you, I will give this a try!

1 Like

You can try with this mission exported as VLM, you’ll see it follows the POI

Thats probably your problem. Export as VLM as @Patrick.33 pointed out and it should work fine.
The KML 3D path doesn’t take the extra settings for a drone flight (gimbal pitch, heading, etc)

I don’t see Export as VLM as an option for the online Mission Hub.

You have to use CHROME and install the extension : Chrome Litchi Virtual Mission - Chrome Web Store

1 Like

No you don’t need chrome (thankfully), the plugin works fine in Mozilla based browsers such as firefox and waterfox

I agree with @Patrick.33
All of the functions of Litchi Mission Hub and more!
One click from the program and it is sent to Google Earth

Ok Martin, the first time I tried, it didn’t work on Firefox maybe because by default the last option was disabled

Just tried when I saw your post and it works now. Thanks.

By the way, the Firefox extension is called ‘Chrome Litchi Virtual Mission’.

1 Like

I’ve got my waterfox set up to automatically open google earth once the kml is downloaded so don’t require step 4 above.

What is that setting translated into English please as I don’t see it on the settings of my version

Glad you got it sorted