Not Keeping Height. Why?

Why my DJI Air 2S doesn’t keep the height from terrain after I have set it up on Litchi to maintain a certain distance.

Above ground altitude is only calculated at waypoints. Drones do not have sensors that constantly monitor altitude.
Make sure you have waypoints set at places that are critical points (in other words, hills).

1 Like

Dear Sam!
All the waypoints are set on Litchi to 120 meters above the ground, as you can see .
What’s it missed ?

Here, in this image the lower ground portion appears wider than the higher one

In the Mission Settings, make sure you have ‘Use Online Elevation’ checked:

As well as ‘Above Ground’ checked in each Waypoint Setting.

When you ‘click’ and ‘Apply’ the Above Ground setting for each waypoint, you should see the Altitude change from the 120m setting to a different number.
Not in the Waypoint setting, but in the Mission View. For example, my WP03 shows an altitude of 50ft in the Waypoint setting, but 85ft in the Mission view since the altitude of WP03 is 35ft above WP01.

Thanks Sam!
I wasn’t used to check On Line Elevation .