No video on older tablet

Hi there,

I have a Samsung SM-T280 with Android 7.1.2. Litchi is starting well, but I could not manage to get a video from the drone camera on the screen.

I believe, the resolution of the video from the drone is too high, as the resolution of the screen is only 1280 x 800.

Can someone confirm this? And is there a way, to lower the resolution from the cam to fit in the screen?

I also got the idea, that there is a way to interpolate the screen with an external tool.

If there is no solution for it, I am working on a solution, using RTMP to this mobile, similar as Litchi Magic Leach does. If I got this working, you will be noticed.



For most DJI drones the Live View Quality is 720p/30fps. Some of the advanced models also offer 1080p.
You can find this information on the DJI Specs-page of your drone.

That looks strange, I tested with the same cable (the short, originally one), which it is working on my other 3 mobiles (these are also older, a Samsung S7 an A5 and a Xperia X10). All worked perfectly.

But on the SM-T280 I got no video.

However, there is an important information: I also tested with Rainbow and UgCS as well (sure you know those), and there no video as well!

Thus I suspect, either the resolution is too high, or, another thing, I can imagine, the interface is too slow. IMHO I bet the first one. However, when, as you told, the transferred resolution is 720p/30fps, what else can I check? Any other ideas?

It is not an important issue, if it can not be fixed, it is ok, too.

Happy flying!


I did some testting.
Samsung Galaxy S3 (2012 Android 4.3) with Litchi v3.10.6 (2017-03).
Works as expected with Phantom 3Pro
Works as expected with Mavic Pro.
Works with Mavic Air, but has some other issues.
Does not work (does not connect) with Mavic Mini.

Ok, it is Android 4.3, which is rather old! I am using Android 7.1, which is much newer.
But I believe, that is not the point.

First, Litchi is indeed connecting to the drone (I can see the green bar as usual), and I also tried with two other apps for this drone, which I know, they are working (Rainbow Pro and UgCS). And as BOTH also connect but do not show the video on the tablet, I believe not a software issue in Litchi.

More a hardware problem in the tablet.

What setting is recommeded for a tablet?
USB-debugging = on?
USB loading akku? Transfer data? Transfer media (MtP)? There are several settings for the USB-port. Tried all, but no success.

I also got developer mode active, and, it is lineageos running (a custom rom). However, lineageos is running on all my devices, also on my Xperia 10 which is working well with Litchi and which is also android 7.1 (like the tablet).

Really strange thing… However, as I said, if there is no solution, it doesn’t matter.

I am very happy with Litchi especially as it is now running on 32-bit.

Best regards


Hi, just to let you know i got the same problem on a Samsung SM-T280 with android 5.1.1
no way to get the video so far ,i bought a Lenovo TB-8705F with android 10
the resolution is 1920x1200 and works just fine, maybe is the resolution like you said