No Connection to Drone

Litchi Version v4.26.8-g
Phone: Samsung Galaxy A41 (Android 12)
Drone: DJI MAVIC Mini1

Have a Problem. My Remote Controller does not connect the Drone anymore.
For the DJI Fly App, the DJI Guy said, my Phone may be not compatible.


The Remote Contact to the Phone is definitively available. The Phone shows
a Loading Confimation once connected to the Remote…

Both worked perfectly two Years ago.

Is there any Trick to solve this?


If this realy is the case, try Linking the Remote Controller, page 29 in the User Manual.

If you turn on both the drone and the controller, and the LED’s on the controller stop blinking after a while, this means the two ARE connected.

Correct, Both Litchi and DJI Fly connect to the remote, NOT to the drone.

Posting one or more screenshots of your problem would help.

If neither app starts up, try uninstalling, then re-installing them.

Worst case scenario: Reset your phone to factory defaults.

1 Like

EDIT. The Drone Lamps on the Back blink red/green.

Yeah, thanks for the Answer.
Drone and Remote are linked. I can fly the Drone with the Remote and initilize Photos and Vides by Remote. But I can’t control the Drone by Phone. The Screen is black
Both Remote and Phone are connected, the Phone gives a Loading Confirmation, so physically they are connected!
I attach you Screenshoot from Litchi. From DJI FlyApp i have even checked some older Version, but they don’t work either.
Litchi is much more better, so I can live without DJI Flyapp.
Both worked paralelly perfect two Years ago. Even bought a second Remote, it worked. Some Days
But then suddenly NO GO. So I left Drone flying behind.
But I want to start again :wink:
Litchi I

According to the screenshot your phone is not connecting to the remote.

Possible causes are:

  1. Faulty USB cable
  2. Faulty remote USB port
  3. Faulty/dirty Phone USB-C port


  1. Try another cable
  2. This can happen by plugging in a standard micro-USB connector the wrong way around. Send the remote to DJI or look for a used one.
  3. Accumulated/compacted dust at the bottom of the port can prevent the USB-C connector from going in far enough. Check the port and clean it with something thin and non-conductive like a toothpick or small tiewrap.
1 Like

So once I connect Phone and Remote, the Phone gives a Message “Loading”. So they are connected via Cable or not? The Phone has an USB C but the Remote USB B. It is an original DJI Cable what worked in the Past and it still connects by Messahe “Loading” on the Phone. I am using already a used second Remote, that worked perfect.I am getting mad :wink:

The 2 outer pins of a USB-C connector provide power (±5V) and are physically longer than the inner pins which are used to transmit data.

In case of #2 and/or #3, the power pins connect but the data pins don’t.
That’s why you get the message “loading” but according to your screenshot NO data is transmitted.
Check and clean the USB-C port of your phone.
I speak from experience.
A lot of dust particles and lint can accumulate in 2 years.

That’s what I wrote.

No, it’s Micro-USB-A.
That’s why a standard Micro-USB-B connecter can be plugged in the wrong way (180° turned which will damage the internal connector in the remote)

1 Like

For Info, I made this with Litchi two Years ago:
Litchi Test

Regarding #3, I speak from experience.
A lot of dust particles and lint can accumulate in 2 years.

1 Like

Here are some steps you can try to troubleshoot the connection:

  1. Restart: A simple restart of your drone, remote controller, and phone can often resolve minor glitches.
  2. App Updates: Make sure you’re using the latest versions of both the DJI Fly app and the Litchi app. Outdated apps can sometimes cause compatibility issues.
  3. Firmware Updates: Check for and install any available firmware updates for your drone and remote controller. DJI releases updates to fix bugs and improve performance.
  4. Wi-Fi Network: If applicable, ensure both your remote controller and drone are connected to the same Wi-Fi network.
  5. Try Different Device: If possible, try connecting your drone to a different mobile device to see if the problem is isolated to your phone. This will help determine if the issue lies with your phone or the drone/remote controller.
  6. DJI Support: If none of these steps work, contact DJI Support for further assistance. They may have additional insights specific to your situation.

Ensure both the drone and remote controller have the latest firmware versions. You can update through the DJI Fly app (if compatible) or DJI Assistant 2 on a computer (DJI Assistant 2 - Download Center - DJI).

1 Like

Hi Guys,
thanks for all your Suggestion.
To give an unsorted Feedback:

I can not use the DJI FlyApp. It has the same result als Litchi: No Remote / Device connected.

Yes I know that DJI Macic Assistant 2. Tried it on my two Computers.
last Night for 2 Hours. Both did not recognize the Drone nor the Remote.
No matter if changing the USB Cables.
Read on the Web, this Software sucks. Yes I confirm that!

The RC Cable and the Slots on the Phone and RC seem to be ok and clean.
Once plugged into the Phone, it confirms by sending three short Loading Confirmations.
So there is a physical Contact anyway. So where should be some Dirt?

“Use another Phone out of our List” - He must have overlooked, that I wrote, it WORKED with my Phone in the Past - now being uncapable?

I attach a Videolink some two Years ago with the same Problem (german Languange).
Some Days later, after buyin a new RC, it work suddenly, but only some two weeks.

I think I do a complete Phone reset next Week after making a Back Up.

If it works and if of Interest, I’ll post it here.

Thanks anyway for your kind attention