Missions planned on website not syncing to Android tablet

I have searched without finding a solution to my problem.

I am logged in to both the website and the app with the same account.

I have uninstalled and reinstalled the Litchi app on my tablet.

I have used the app once before to fly a mission but when I was onsite yesterday nothing appeared within the app to indicate I had a mission available to use.

Is there any way to determine whether a mission has synced successfully and/or is there a method of manually load a mission into the app?

Thanks all for any suggestions…

On your tablet, check the setting:

Sync Local Missions : When enabled, and provided you are logged in to your Litchi account, missions created on the device will be synced to the cloud so you can access them on other devices.

Oh my goodness… it’s always the easiest solution isn’t it? I probably glanced right past that 10+ times yesterday.

Thank you very much Sam_G.

1 Like

I spoke too soon. The sync local missions options was turned off but after turning it on it still does nothing.

I closed and reopened the app multiple times, I tried two different wifi networks, I uninstalled/reinstalled the app (logging in with the same account as the website where I planned the mission) yet it does not sync. Unsure what to do at this point.

The “Sync Local Missions” option is only for syncing missions “local” to your flying device back to the cloud. It has no effect on missions already in the cloud.

The syncing process just works if:

  1. You are logged into the same account in both the Mission Hub and in the Litchi app.
  2. Your flying device with the Litchi app is connected to the network.

This will require some troubleshooting on your part. First, verify that the Mission Hub shows the missions you have created. Second, verify that the device on which you have Litchi installed is connected to the network. Can you bring up the Mission Hub on your flying device and see your missions? Then, select the missions folder inside the Litchi app on your network-connected device. There is nothing magic about this. If you are using the same account for both both are connected to the network, it will work.

The mission hub on my desktop computer shows all of the missions I have created, including the old mission from half a year ago that I did not have any issues syncing with.

I have tried two different networks on the tablet that I am wanting the missions to be synced to. Neither option allowed syncing but (edit: the networks) were able to utilize the internet - so the network itself is working properly.

On my flying tablet, if there is a Mission Hub option within the app then I am unable to locate it. I went to flylitchi.com on the tablet’s browser and every normal option is available (adding missions, batch edit etc.) but there is not a Mission Hub option in the lower left where it is on my desktop browser.

I am not a stupid person, I understand that it can be frustrating when trying to help somebody troubleshoot technical issues but no, I don’t expect this to be “magic”. I simply don’t understand what I did 6 months ago versus now to cause my tablet to no longer automatically sync.

I’m not frustrated or trying to be combative back to you and I also re-tried all of the things you mentioned, just hoping somebody else has experienced this same trouble and can maybe read through the thread and find the missing piece.


The Mission Hub options on the tablet browser was hidden, I opened the map in Fullscreen and it was available for selection.

When I (or anyone) says “Mission Hub” we are talking about the web application that is part of Litchi’s web site. The Mission Hub is not part of the app. On your flying device, start your web browser, go to Litchi’s web site, click on the Mission Hub link, make sure you are logged in to your Litchi account. Do you see your missions?

I have never experienced this but here’s a sugestion:

Since you haven’t used Litchi for a long time, the issue is perhaps related to the DJI policy they will log you out of the DJI Fly app after not using DJI Fly for more than 52 days.
Perhaps the SDK does the same thing.
Try the General Setting “Check and Sync License” in the Litchi app.

Yes, I have the same functionality on the tablet’s browser as I do on my desktop.

I see all of my mission names located in the android/data/com.aryuthere.visionplus/files/missions/_users/ folder.

Should I be seeing the missions on the Aerial map? I have no hooked the tablet back up to the drone so if that is the additional missing function then I’ll try that next.

Thanks for the help.

That confirms that your missions are in the cloud. (We already new that because you could see them in the Mission Hub on your computer.)

That suggests the missions are syncing from the cloud to your app.

I’m not sure I completely follow. No, the drone does not have to be on and connected to make this work.

Try logging out from inside the Litchi app, then log back in, in the Litchi app. Any difference then?

Well… I resolved the issue… maybe I need to take back what I previously said about not being stupid.

Yesterday, (when I did not have sync local enabled), I tried pressing the FPV button in the upper left and nothing happened (edit: that I recall).

I pressed it again today and as we can all assume, the Waypoint option is available. I selected it, and the folder icon allowed me to select all of the missions that I had sync’ed up.

For clarification sake though: It is not necessary to visit the website on the mobile device, I just tested with creating a flight plan on my desktop computer while I had the app open on my tablet. The mission instantly sync’ed.

Apologies to all for my error, I believe that not using the app for all this time caused me to forget the simple solution. I greatly appreciate all of the help that everyone was trying to give.

What you are saying here is different from what you were saying before. We had all assumed that your missions weren’t syncing – the waypoint folder was empty in the Litchi app. Now, I think you are saying that you weren’t even in the waypoint flying mode so that the waypoint mission folder was not even available to be selected.

Correct, I am explaining that this is a classic case of Occam’s Razor and user ignorance. It had been so long since I last used the app that I could not recall how missions were selected.

I was too glued to the idea that the missions appeared on the aerial which is why I was so confused.

The sad part is that when I first downloaded the app it was so intuitive to me that I more or less went straight away to the FPV/Mission/Etc. area of the app.

I’d blame my age but I know there are many users who are older than me.

The troubleshooting assistance you all provided definitely helped though, without it I would have given up.