Mission hub on ipad-no home

Haven’t been using litchi for a year but read that IOS is now supported for missions. I’m unable to find the home button that was always on my laptop in windows. Any idea how to retrieve that on an iPad or iPhone? Thanks

Your subject says “Mission Hub” but when one just says “Litchi” one normally means the Litchi app. Missions have “always” been supported on IOS with their app. However, the Mission Hub web application has now been made more mobile-friendly.

The home button/icon in the Mission Hub is found in the upper right hand corner. It looks like a bullseye.

The only iOS device I have is an iPad Air2 (iOS 15.7.8). The Mission Hub page will not open. Every other tab of flylitchi.com will open (Home, Whats New, User Guide and Forum) but not Mission Hub, even after I successfully log in.

Safari nor Chrome were able to open the Hub.

Error message “Cant open this page”
Tried Chrome’s troubleshooting tips (Open in Incognito tab, restart Chrome app and restart device)
No success

1 Like

The same goes for the iPad Mini 4 iOS 15.8(19H370).

We fixed the issue of the hub not loading on older iOS devices/versions (<=iOS 15)

1 Like

I’m using an iPad Pro with latest OS. It’s inconsistent when going to the mission hub. Every 3rd time (approx) the screen wobbles madly and freezes. When I click on the world ma- to view other missions, the screen appears but not always able to zoom in without freezing. Or the map seems to “slip” down on the screen. I’ll attach a pic.

I recall on my laptop that I was able to construct missions on the mission hub. On my iPad there are no POI icons, there is no lock mission icon.

No biggie. I’ll use the litchi app to do missions but figured you’d want to know.

I was able to reproduce what you show in your screenshot.

I have an iPad Mini 5 running IOS 17.1.2. To get the view that you showed, I opened the Mission Hub, selected the “Discover Mission” icon, then pinched to zoom way out. The map snapped to the bottom and the tab froze. I was able to close the tab and open the Mission Hub again but I could not reproduce the freeze.

The POI icon is shown in your screen capture in the upper left corner. It is the fourth icon down. The “Lock Mission” icon is part of the Litchi app. It has never been in the Mission Hub.

Also, the “Home” icon that you initially posted about is shown in the upper right corner of your screenshot.

We’ve made some improvements to try and prevent this issue, thanks for reporting it!

Thanks for those improvements. However, after more experimentation, I find it is far too easy to get the Mission Hub to lock up.

I know that one normally would not do this but I have found a way to reliably lock up the Mission Hub on my iPad Mini 5 (IOS 17.1.2). Steps to reproduce the lock-up:

  1. Select the “Discover Mission” icon.
  2. Repeatedly pinch the screen to zoom out.
  3. If the pinch begins with a finger on one of the “Discover Missions”, the screen goes wacky (I’m not sure how to describe it) and then it locks up.
  4. You can then scroll vertically but not horizontally.
  5. The only way to continue is to close the tab and start over.

Here are a few screenshots to show that it can be easily repeated:

The issue should be fixed.

I can still get it to lock up pretty easily using the same method I mentioned in the previous post.

Have you tried in an incognito tab? (Browser cache files can still use the old script)

I have tried in a “Private” tab on my iPad Mini 5 and on another iPad which had not previously been used for Litchi’s Mission Hub. In both cases I can get the Mission Hub to lock up. However, it is much more difficult now with your recent changes. I would consider this bug resolved because of the difficulty in getting the lockup to manifest itself.

1 Like