Mission hub menu to big

When I left click on a waypoint the menu opens but it’s too big! It’s starts at altitude and to exit I have to press esc key on keyboard

That would indicate that you have a very low-resolution display. What kind of computer are you using?

There are keyboard shortcuts but we should figure out the low-resolution issue first.

I have an i5 16 GB ram, display is 1366 x 768

@Frank_Jerome, are you saying that the Waypoint menu is too large and takes up too much of the screen? This screenshot shows the menu taking up about 40% of the screen and I believe is typical. Or are you saying that the upper part of the Menu is cut off? (Longitude)

Yes, it’s exactly like the photo

I have a similar computer so it should work fine, but like @wesbarris was saying the resolution is probably the issue. Here is something you could check out to see if your computer settings are ideal. I hope this helps.
Why is my screen Display so large?

Image result for display too large

Open the Start menu and select Settings. Go to System. In Display, check the Scale and Resolution options, and adjust them to make your screen look proper. Setting to an option labeled (Recommended) is often the best choice.

If your screen is the same as mine then I don’t know if there is anything else you can do.

I tried different settings with no luck and but back to the recommended

I appreciate your help, thank you

1 Like

That is a relatively low resolution. Keep your display settings at their “Recommended” values.

You have two choices:

  1. Use keyboard shortcuts: left and right arrows to cycle between waypoints. Ins and Delete to insert or delete waypoints.
  2. Use Control-Mouse wheel to temporarily scale your display (while your mouse pointer is inside the waypoint dialog). Use Control-0 (zero) to reset your screen scaling back to the default.
1 Like

@wesbarris, would you show us a screenshot of what your waypoint menu looks like since mine looks the same as @Frank_Jerome with the lower resolution screen than you have. Thanks

Use the zoom function in chrome by clicking the 3 vertical dots in the upper-right corner and choose either full screen or a zoom factor of about 75%.

1 Like

This is mine on my laptop with the browser zoom level set at 80%

These are the windows display settings

1 Like

Here is a snapshot of Mission Hub with the browser window sized to partially hide the waypoint dialog.

Each browser may have a different way to set its own scaling. Holding the Control-key down and scrolling the mouse wheel is the easiest way to adjust the scale. This works in Firefox, Chrome, Edge, and perhaps others. Here is a view of that same window with the scaling set ridiculously small.


Thanks everyone!!! The Control-key down and scrolling the mouse wheel works perfectly!
Thanks again for all the help


Hit the F11 Key on your keyboard.

Thanks it is working now

1 Like