Mini 3 Pro ~ RC Pro ~ DJI Fly Logged Out ~ In Normal Mode ~ Geo-Zone Unlocked

Question: Will Litchi Pilot allow missions with my set-up mentioned in the Topic title.

I’ve ran a few Litchi missions (outside of NFZ’s) flawlessly.
My M3P flies is the geo-unlocked zone where the mission is…
Inside the Geo-unlock zone, my mission will activate… the drone will leave the ground in a stand-by phase, but when I press to choose the waypoint to start in, it tells me the mode has change.

Am I spinning my wheels here… or is there a way I can execute the Litchi missions I want to fly…

Thanks in advance for all info…

P.S. Yes I’ve search and read other info… but it’s dated… wondering / hoping there’s been some updates / work-arounds

If I understand what you are asking (sorry if I misunderstood), yes, you can unlock an “Authorization Zone” and then fly in it using Litchi Pilot.

The unlocking process must be done using DZI Fly and the token must be loaded into the drone. Also, there is no need to log out of DJI Fly. All you need to do is stop DJI Fly and then start Litchi Pilot.

Ok… great… I’ll give it a try…

do you know what the difference is between doing the log out… and doing the forced stop… and what does it mean when it’s says “mode changed”… (or something like that.)

thanks again for the info… much appreciated… Hopefully it works… it’s a project I’m comp’ing for a Horse Rescue Foundation… I’ll share footage and explanation if (WHEN!!) it works…

I don’t understand the comparison. Those are two unrelated things. Logging out of your account is unrelated to force-stopping an app.

“Mode Changed” could mean a number of things. However, in this case, it is referring to the fact that you are in an “Authorization Zone” and the mode is changed to prevent you from flying.

Wes… thanks for all the help…

Went out early this morning, back to the geo unlock area… did the forced stop on DJI… drone will leave the ground into the stand by phase… but when I choose the waypoint to start in it says “mode change” which as you mentioned… is preventing me from flying.

So I guess I can’t fly in Geo Unlocked Zones… Then oddly enough, I went back to the first place I tested Litchi Pilot… (with no problems) and it kept losing signal… it would elevate a few feet… then cut out… it never got half way to the starting point of Waypoint #1

At this point I can’t put any trust in the app… I can certainly see a great use for it… via setting out flight paths… sending the image to a client… and they can sign off on it, or ask for changes…

Thanks again…much appreciated.

You didn’t say, so I have to ask. Have you used DJI Fly to load the Authorization Token into the drone? If you have, then I am at a loss. I have done this process using DJI Go4 and the old Litchi app and it has worked for me. I don’t have the Litchi Pilot app, so I’m wondering if a different process needs to be followed.

Hopefully, someone who who is using this app and has unlocked an Authorization Zone, will chime in and provide the missing details.

Have you just tried to fly (using Litchi Pilot) in the Authorization Zone? Don’t try to fly the mission, just make sure the zone is unlocked and then manually fly using Litchi Pilot.

So… yes I have passed the auth token onto the drone… and have flown the drone (via DJI Fly) freestyle in the same unlocked zone…

I was not aware I could fly with Litchi and no mission… would I need to force stop or log out of DJI Fly before I do that… (I know the quick answer is “just try it…lol… but the location is 30 klm’s from my home”)…

I will go out and try and fly with Litchi first outside of a auth zone… then consider the 30 klm drive again…

I’m also going to contact Litchi and see what they say about Litchi Pilot and Auth zones… as it seems… many using FlyLitchi have no problems… but most using Litchi Pilot are having problems…

Thanks again Wes… (sorry… I’m Canadian… we say thank you all the time…lol)

Sure, why not? There is nothing forcing you to load a mission and press “execute”.

That depends on whether or not you have he camera view in Litchi. A blank camera view is normally a sign that the DJI app needs to be force-closed.

I get the camera view… it leaves the ground hovers at about 5 feet, awaiting the waypoint start choice… and when I push the button… “mode changed”

I have an email into litchi… I’ll wait to see what they say…
But a this point… it doesn’t appear to be a solution I can trust in
the air, or as a service / feature I can offer to anyone.

thanks again…

Just try to fly your drone. Don’t do a waypoint mission.

I’ll try when I go out tomorrow morning

Try with DJI Fly and then with Litchi. If the token is loaded into the drone, both should work. If DJI Fly works and Litchi does not, something else is going on.

Official response from Litchi Support:


If by FlyLitchi you mean Litchi’s Hub, then it is already compatible with Litchi Pilot and the Mini 3/Mini 3 Pro.
I believe currently you won’t be able to fly in unlocked flight zones as we have to implement the DJI unlock system in Litchi Pilot for it to work and it is not done yet. At some point we will implement a way for you to log in to your DJI account and download unlocked no fly zones and then it should work. However please note currently it is not the priority so it may be some time before we get to that.
In the meantime, you could try to take off with the DJI app, then switch to Litchi Pilot and start the flight however I am not sure if it will work well."

I haven’t tried there suggestion yet. Doesn’t seem like it will work

Thanks for posting that.

Here it is unclear if they are referring to flying in an unlocked area or the system by which areas are unlocked. The standard Litchi app does not have the ability to unlock a zone, yet you can use it to fly in a zone unlocked using DJI Fly or Go. Since they mentioned logging into your DJI account, it almost sounds like they are referring to the unlocking process.

This is worth a try.