Mini 2 going everywhere during waypoint mission

Have been waiting for mini 2 support for over a year, but I’m very disappointed. The waypoint missions are a total disaster. no straight lines at all. The drone is going everywhere, drops 10 meters for no reason, keeps trying to reach the next waypoint by circling around it, and I almost crashed in a roof because altitude was way off. It worked perfect with the Mavic Air, but Mini 2 support is a joke I think.
I have tried this several times, but keep getting erratical flights. This morning was my first waypoint mission without problems, but unable to repeat it. It seems the least amount of wind totally screws the mission.
After landing, I noticed that the programmed ‘take picture’ was not executed, as well as the ‘Start recording’.
Anyone else getting buggy results?

I’ve flown several waypoint missions with no problems with my mini 2, the latest one can be seen here

1 Like

Actions at wayoints will only be executed when in Mission Settings → Heading Mode is set to Straight Lines. They will be Ignored when set to Curved Turns.

Have a look at this topic:

1 Like

I had issues with waypoint settings too. I had it set to take pictures only all on straight lines no curves in the mission. I had it set to wait 3 seconds at each waypoint before taking a picture. It took 2 pictures out of 6 one was facing the opposite way, all set to focus on one POI. It was a basic mission just to test it. I did reset the compass but didn’t try flying it again because of the wind, maybe the compass and wind had something to do with it.

I think it is because in my settings it wasn’t set to straight lines. I had it set to curves but slide the slider to 0 in the curves. I will reset it to no curves and try again this week and will update.

1 Like

How much does he tilt the camera along the horizon when flying to the sides

Hi, i got problem to take picture in a mission and a guy name wesbarris gave me these instructions and it is working :
1-* Stop recording
2-* Wait for 1 second
3-* Take photo
4-* Wait for 1 second
5-* Start recording
i also got problem in a mission at waypoint 20 my mini2 was just circle aroud the waypoint 20 and cannot finish the mission, had to call a RTH
i change straight lines to curves and i retry the mission , done successful !

and finally i watch a video on youtube that the guy had problem with the height and was just updated the firmware to 01.04,000
maybe could have something to do if you update to the latest firmware
hope could help,Gordon

1 Like

.Naturally. You can even put 5 seconds. There will be great photography.

That’s due to an unsufficient control signal quality.
Have a look at post #4 d.d. March 28:

1 Like

I noticed that the latest firmware caused some issues relating to height and heading.
I don’t own a mini 2 but many users that have one are reporting these issues.

Mission can be found here

Ok thanks, but when i put curves at the place of lines it complete the mission, maybe was just a better signal, i will retry it with straight lines and see what will happen
thanks, Gordon

Hi, you were just wright! i tried a second time , it failed and i saw just 2 bars red for signal
and i modified the height of the mission and it worked just fine
thanks again , was useful

1 Like