Mavic Pro with Obstacle Avoidance OFF Still Hits the Brakes Randomly While Flying Litchi Missions

I already posted this write-up over at the Mavic Pilot’s forum, but being the impatient type, I decided to post it here as well. This is a problem that I was sure I had resolved, but it came back with a vengeance, so once again I’m hoping someone here might be able to offer insights as to just what is afoot.

I’ve repeatedly run into a problem that defies logic. When I launch my Mavic Pro 1 on Litchi waypoint missions over some but not all locations, with all obstacle avoidance and landing assistance sensors switched OFF in both Litchi AND DJI Go4’s settings menus, the drone randomly pauses and hovers multiple times for no apparent reason.

For the first time today, despite my RTH altitude being set at 240 feet, the drone ascended higher each time it started moving forward after another uncommanded pause until it was well over 500 feet up, which is an utterly bizarre flight behavior I have never seen or heard of in the past.

This behavior has resulted in my nearly losing the drone more than once during Litchi waypoint missions because all those uncommanded pauses drain the flight battery down to dangerously low levels before I regain control and use sport mode to get the drone home,

This random stopping of the drone while flying Litchi missions is baffling because this sort of anomaly is only known to happen if obstacle avoidance sensors are left on prior to launching Litchi waypoint missions. Since I check and re-check to ensure that all the drone’s obstacle avoidance ultrasound sensors and landing assistance cameras are turned OFF, I am at a total loss as to what is causing this drone to repeatedly tap the brakes entirely on its own accord.

Any suggestions as to how this annoying pause can be eliminated would be appreciated. Thanks in advance.

I intend to fly this same mission with my trusty old Phantom 3 Standard today, and my hunch is that the mission will be completed without a single random pause and hover. There is a lot to be said for the simplicity of older drones that didn’t come with all the extra bells and whistles.

If the Phantom does not repeat this strange stop-and-go behavior I can then conclude that the problem I’m facing with the Mavic Pro1 is NOT related to Litchi, but to the Mavic Pro 1.

With the information posted here, all we will be able to do is guess at the cause. If you want to know the real reason for what you described, you will need to analyze the logs. There is an excellent tool that will show you some important data and any warning messages produced by your drone during that flight. It is available here:

There are some very experienced log analysts on the Mavic PIlots forum who will want you to post a link to this log viewer so that they can help you determine the cause of these anomalies. It will be interesting to hear what you find out.


Much thanks WesBarris. I’ll see if I can’t exhume the flight log to post here and at the Mavic Pilot’s forum. I am definitely going to stop flying both my Mavic Pro and the Mavic Pro Platinum until I can find and eliminate the cause of the random stops along that Litchi flight path, and the inexplicable stepwise ascents that also occurred to my dismay, taking the drone up to 500 feet which is more than twice the RTH altitude I set.

This fiasco unfolded beyond RC signal range, so I only witnessed the tail end of it before hastily switching to sport mode and pushing the nose down for one final sprint home where the drone landed with just 8% battery. That was a close shave that really put me off flying the Mavics until this mystery is solved.

Playing back the footage of the flight, I lost count after about 40 instances when the drone stopped, swiveled left and right briefly, then lurched forward, only to stop again a few feet further along the RTH flight path and repeated the swivel dance. To describe that behavior as exasperating to behold would be an understatement, especially since I was dead certain that all obstacle avoidance was de-selected on the settings page.

Hi there,
You WILL lose the Mavic Pro one day if you continue to fly it WP with Litchi. I lost 2, years back because of my stupidity. I insisted flying WP after I got warnings as you did. I experienced mission pauses and auto landings. Just like you all sensors off and no problems with flying the same missions with P3. Always there was not battery issue
Mavic Pro is DJI first from the series and I believe that they messed it up with the “redundant” compass and the position of the second compass tighter with the GPS in the tail area

In MP 2 they got rid of the second compass (if I remember well) and placed the GPS central.
Going back to MP 1
It is randomly happening and no log reading expert will solve it. Is either a hardware/software issue with some of them or all of them.
Just keep it in eyesight always while flying WP. This is how are supposed to fly it anyway isn’t it ?

I forgot to update this thread with a response from the Mavic Pilot’s forum that I hope, knocking on my wooden noggin, will prevent my Mavic Pro from doing that odd stop-and-go dance.

A gentleman in South Australia called Mereflyer responded to my post on this subject by relating a few incidences when he encountered the same identical symptoms. Turned out that he was able to solve the matter once and for all by calibrating everything that can be calibrated on the Mavic Pro1, after which his Mavic Pro1 never again stopped during Litchi missions.

Its been raining cats and dogs here, but when the weather breaks I plan to go the whole hog and calibrate the IMU, the GPS, the Camera Gimbal, and the obstacle avoidance sensors, in the hopes of seeing the same resolution the Mavic Pro1 owner down under saw after his calibration of everything in sight.

I’ll report back here when I’ve finished all the calibration rituals and tried out a couple of test flights.