Maps Discrepancy - Satellite with Label vs Map with Terrain

Is the Satellite view defacto for accuracy in planning waypoints compared to the Map view? Which one presents the best accuracy for mission planning?

Lots of questions now… am going to try a few scenarios to see. My first trial with waypoints missions in Satellite mode with Labels does not match with Map view with Terrain. The overlay/alignment of the maps is way off to give confidence.
On Mission Hub web the default map is Google. On iOS I had the chance to switch from Google to Apple Maps.
What happens when i switch the base map for an already setup mission?
Which mapping interface - Map or Satellite - gives better accuracy? Anyone with a clue on this can share their ideas.

Check this:

This is a known problem with Google maps in China. It is due to restrictions on the use of geographic data imposed by the Chinese government. I do not know whether the aerial data or street data is correct.

I have never tried them, but there are two settings in the Litchi app called:

  • Use Amap Imagery (for China Mainland)
  • Calibrate Map for China Mainland

I have never tried these but my guess is that they would at least fix the map in the Litchi app for China. I am not aware of any equivalent option for the Litchi Mission Hub.

Interestingly there is an option to switch maps provider. With Google Maps not available in China I switched to Apply Maps on my mobile phone. Apple Maps on my iPhone and had the same occurrence. So is it more or less a general problem? The Point is that which map to use? Because both Raster and Vector maps are simply not reliable.
Maybe it’s time to put a note on users buying from China to say it’s not available in China? Because am not having similar problems with others.

I don’t see Amap in the Map Engine and I don’t see Calibrate Map for China Mainland. All I have is Map Engine - Google, Apple. For Calibrate I’ve got only Calibrate GPS.
I will try to install Amap separately.