Maiden Flights Interrupted

Total newbie with Litchi and could use some expert help. Set up two initial flights to circle the neighborhood and our house that’s under construction. Two issues came up.

  1. I set up waypoints on each corner of a rectangular block and used the arc function to smooth the flight path to an easy curve. At each corner, I set the direction of the drone to the next section of straight away. For some reason, the drone slowly turned on the straight aways instead of aiming down the street. Don’t know if I’m supposed to set two waypoints at each corner with drone direction into and out of the corner or what, but it didn’t do what I expected.
  2. I assumed I could let the drone fly the automated path and all I would need to do is rotate the camera up and down, but for some reason, Litchi cancelled the automated flight about halfway through its flight saying the routine was interrupted. Can I control the camera pitch during flight? Did I interrupt the flight by adjusting the camera? Can you override the automated routine manually with the controls (maybe I moved the controls unknowingly). If the routine is interrupted, can you restart it?
    Would appreciate any help in these matters…

First you need to know which drone

Then can you share the mission

As long as the drone is within the signal range of the controller, you can tilt the camera to any desired pitch as the drone flies a Litchi waypoint mission. If the drone is likely to fly beyond the reach of the controller, then you’d need to disable camera pitch in the settings pull-down menu when you are initially planning the flight, so as to manually adjust the camera’s downward angle using the controller’s thumb wheel as the drone departs, while the drone is still within range of the controller.

That way the camera will retain that pitch angle you set with the thumb wheel until it returns. If the drone flies out beyond the signal reach of the controller, the camera will retain the last pitch angle you manually dialed in shortly after the drone’s departure to the first waypoint of the flight plan.

You could place one or more points of interest along or beside the planned flight path, and then in each waypoint’s individual settings menu page, select the Point of Interest POI that you’d like the drone’s camera to focus on as it flies along its assigned course.

Regarding the unexpected disconnection of Litchi, it is possible that you accidentally toggled the controller into sport mode and out of GPS mode, which then terminated the waypoint mission, but this is speculation on my part.

1 Like

This is the normal behavior for missions where the “Heading Mode” is set to “Custom”. The drone’s heading will smoothly change from the heading defined at one waypoint to the heading defined for the next waypoint.

If what you want is for the drone to always point tangent to its flight path, you could set the “Heading Mode” to “Auto (TNW)”. When doing so, ignore the direction the drone icon is pointing on the last waypoint in the Mission Hub. The drone will always point itself along the flight path.

If you wish to manually control the gimbal pitch angle during flight, make sure that the “Gimbal Pitch” is set to “Disabled” for each waypoint.

1 Like

Appreciate the input. Sorry, to all - I’m flying a DJI Air 2S. I wasn’t using a POI so there was nothing for the drone to look at specifically. I am curious about your statement about flying beyond the range of the controller though. How does that work? Is the entire waypoint mission uploaded to the drone when it begins so it can fly without staying connected to the remote? I agree. I could’ve changed the GPS mode inadvertently…

Appreciate the Auto (TNW) input. That’s exactly what I needed.