Losing connection on waypoint mission on DJI Air 2s?

Hi,

I read a comment that the DJI drones that uses the FLY app (not GO4 app) won’t finish the waypoint mission if it loses the connection, but RTH. Does anyone know if this really is the case? I bought the app today and am planning an A to B waypoint mission. I know I will loose connection while driving to point B. The stretch is also too far for the drone to get back to the start. In addition it is over water so landing would be a pretty bad idea.

Has anyone used the DJI drones that uses the FLY app on waypoints and lost connection? What can I expect haha.

Thank you,
Sander

Yes that is true, drones that use DJI fly cannot continue missions beyond signal loss. It will execute the “Signal Lost Behavior” setting of your choice instead (by default that’s RTH): Help - Litchi

Ahh, I see. Do you know if this is a limitation to the new DJI drones, or is it something that might be available in a future update? Thank you!

It is a decision made by DJI starting from Mini 1, it is doubtful they will change it.

Hello. I created a route for the waypoint, I launched the drone (DJI Mini SE) and after the 3rd point at a distance of about 20m, the drone stopped in the air at the set altitude and stood there motionless until I gave it the command RTH . The distance to the remote was on the verge of losing signal, but I still had poor control over the camera. I did another route closer to me that he did correctly. Then I did a longer route again and again the drone stopped on the route.

Yeah, I also tried it yesterday, but experienced the RTH when it lost signal. Kind of make it feel more safe, even though the missions would have been easier in one go!

So I understand that when he lost the signal the mission did not continue and RTH was initiated?

Yes, it started to return.

I never timed it, but the “Signal Lost Behavior” setting (RTH (default), Land or Hover) takes a few seconds to activate.
In my experiences about 15 to 20 seconds.

When the signal-loss is 100%, the RTH command from your controller/app will never reach the drone.

I lost signal on my 3rd Waypoint (out of 4)
1.5 minutes before the drone decided to come back.

However, I don’t know if it was due to me flipping it from Cine to Normal mode or pressing the RTH button on the RC?

Pretty scary, but it finally came back.

I’ve tried the waypoints a lot for the past days. It feels really safe if you set the settings in the missions hub to “RTH” as finish action, and lost signal behavior to “RTH”.

FWIW, if the reason isn’t obvious to everybody already… The reason is because when you lose connection you are probably out of sight. That should certainly be the case with the Mini 2, you are probably WAY out of sight.

Yes, that is pretty clear. I do however know that older DJI drones (the ones that uses the GO app) could finish waypoint missions even though signal was lost, as the mission was loaded directly on to the drone. I wondered if that was the case with the drones using the FLY app as well, but have found out that it isn’t. So I’ll just have to do bigger a to b missions in several takes.

I had an incident today with my Mini2, it would lose connection erratically and waver to get to the next way point, and the altitude showed < 10 ft (should be 100 ft) so I immediately pressed the RTH button. It came back to me and was landing, but another weird thing happened, I normally as it is landing (10 ft up) click the RTH (short press) to stop the landing so I can correct the landing spot, and instead of aborting the RTH, it immediately flew off (wo ascending) straight to my left and hit the house next to me, Fortunately, the drone survived and only lost my ND filter. I was wondering if Litchi app thinks if I cancel RTH, it tries to resume the mission? This scared the heck out me,

No. The rth button on the remote works independently of litchi. What did you press?

When it was started to land. It was about 10 ft above me when I short pressed the RTH button. I’ve do this all the time to cancel the RTH when it is above me using the DJI app. That’s what took me by surprise that the Mini2 took off to the left at a high speed.