Load Flight box empty

It’s been a long time - maybe a couple of years at least - since I have used my Mavic 2 Pro, let alone Litchi.

Having switched everything on and got all the firmware and software versions up to date on the drone, the controller and litchi, I am finally logged in.

Weirdly, I am not seeing any of my saved waypoint missions on the controller when I go to ‘load flight’.

However, when I launch Virtual Litchi Mission, I can see them all just fine.

Any ideas why this is the case?

The Litchi version on the controller is v4.26.8-a

In GENERAL settings you should check:
-Sync Local Missions: On/Off
-Check and Sync License

Check the Mission Hub to make sure your saved missions are there.

And make sure you are using the same login/password combination in the Litchi app.

Thanks for the reply. I’ve checked this and sync is on. I also synced the license. No change.

On Mission Hub I see all my missions:

But on the controller, the box is still empty.

Any other suggestions?

Additionally, if I create a basic test mission on the controller and save it, I can see it on the Mission Hub on my PC, along with all the others.

And even more additionally (!), I just created a new test mission on Mission Hub, and it has appeared on my controller.

So could it be that all my older missions are no longer compatible?

I have not heard of this happening before. The only things that should be necessary are to be logged into both the Mission Hub and the Litchi app with the same Litchi account and the occasional need to select the “Check and sync license” option.

What happens if you open an old mission on the Mission Hub and then save it again. Does it then appear in the app?

I’ll give that a try.

FWIW, I had this same issue last week with my Mavic 2 Pro. I had to open each flight in Mission Control and save them, then they appeared on my Smart Controller.

I had the same issue recently. The only thing that worked for me was deleting the Litchi app from my Smart Controller and reinstalling it. Everything returned to normal after that.