Live video feed does not work on Galaxy A53 5G

I only see Google maps. I uninstalled DJI Fly App (which did show video feed) to ensure there was no conflict.
Video recording to SD card works fine, I just can’t see live drone camera video on my phone.

1 Like

Perhaps you somehow (accidentally minimized the live feed video window.
Check if you have a “+”-sign in the right bottom corner of the screen and tap on it.

Thanks Tribar. I do have the plus sign at the bottom right of a black screen (apart from icons):
When I tap it I get this:

When I tap the Google map, I get the google map maximized

You could try tapping the VR-button (upper right) to see if that works, or changing the screen resolution in the phone settings and/or another USB-cable.
Otherwise I’m as lost as you are.

Thanks, but no joy in mudville!
It’s irksome that it works just fine in DJI Fly app.

Most likely same bug as the S22 if you have exynos + android 12: Known Issues with current release versions

DJI told us it should be fixed end of june

I have Galaxy A53, version 12, powered by Exynos 1280 mid-range chipset.

Am I toast until June earliest?

1 Like

i’m so bummed. i just got the app a couple weeks ago and was so excited about waypoint mission planning. it worked flawlessly a couple weeks ago. now no live video feed. i have an a53. i sure hope it is fixed. i have so many missions planned.
Known issue Live video feed does not work with the Samsung S22 and Galaxy A53 with Exynos processor (Qualcomm Snapdragon processor is supported). We will update as soon as DJI fixes it in the SDK”

Hey Curtis. It is a pain that it won’t be fixed till end of June earliest. You can still use the Litchi app, missions etc. but not watch on your phone as they happen. I will be riding a motorcycle through the missions so I won’t be looking at my phone anyway.

I’m brand new to using Litchi as of this week. I flew a test waypoint mission yesterday and it went fine with the exception of no live video from the Mavic 2 Zoom I was flying. Everything else was great and it recorded to the drones’ SD card.

I am using an older iPhone 6S with 64GB of RAM and it’s worked flawlessly with the DJI Go 4 app for years.

Any suggestions beyond the USB cable suggestion and uninstall/reinstall the app? I like the ability to pre edit and create missions online with the Mission Hub. Otherwise I can create very similar results with the built-in Waypoints feature in DJI’s software.

Also, Is there any chance of automating the 2X optical zoom while flying a waypoint mission? I was prepared to manually adjust the zoom during the flight, but could not see anything due to lack of live video.

I’m having the same issue. i see this was written in 2022. is there a fix?

This issue (no video feed on Galaxy A53 5G with Android 12 & Exynos processor) has been fixed.

I flew today and couldn’t see camera view. Is there a setting I need to change?

You have to Force Close any DJI app before starting Litchi (Pilot).