Litchi Not Running on DJI Smart Controller

I just downloaded Litchi through the Google Play store (Black Friday deal) and then used APK Extractor to extract the APK, then transferred it to my DJI Smart Controller via Bluetooth.

Upon installing the Litchi, the app appeared as the generic green Android icon. When I clicked the icon, I got a blank screen, followed by a pop-up stating that the app has closed. After clearing cache and rebooting, same result.

I then tried installing it through Amazon App store and got the same results. I was unable to find any posts by users with the same issue. Note that I just installed new firmware for my Smart Controller, so I’m wondering if the new firmware is incompatible with Litchi. Please let me know if you have any suggestions.

drone model - DJI Mavic 2 Pro
mobile device model - DJI Smart Controller 
the Android or iOS version you are using on your mobile device - Android 7.1.2
the Litchi version (see settings) you are using - 4.26.2-g
the DJI firmware version you are using - 01.01.0072
1 Like

The -g (google) version of litchi does not run on dji monitors (unless you somehow manage to install google play services on the device).

For dji monitors you need to buy and install the -a (amazon) version.

You can find instructions here:

1 Like

Thanks for getting back to me. As I mentioned in my original post, I tried downloading from Google for the Black Friday deal. When that failed, I reattempted installation through Amazon and got the same result.

1 Like

@Jay_Conner, sorry for the trouble you are having. The link I tried to put up didn’t work for some reason, however there are videos that say Litchi can be installed. Google “Installing Litchi on DJI Smart Controller” and see what comes up for you.

Thanks for the reply - I’ve read the instructions here at flylitchi.com, and also watched a YouTube video covering how to install it on the DJI SmartController.

1 Like

If everything mentioned has failed to work for you, then maybe you are dealing with a BUG of some kind. Deleting and reinstalling apps often works. If nothing else you could try a factory reset with the controller.

There’s no such thing !

The latest DJI Controller with build-in screen is called ‘DJI RC’ not ‘Smart Controller’.

The DJI RC isn’t even compatible with his mavic 2 pro.

He has the ‘Smart Controller’.

This also means that your 2 posts in the other thread (about the DJI RC) are TOTALLY off topic and should be deleted !

The only correct way to install litchi on a Smart Controller is by first installing the Amazon Appstore App for Android on the Smart Controller, then BUYING and installing the -a version of Litchi (v4.26.2**-a**).
This because of the different licensing systems between google and amazon.

Also:
The file created by APK Extractor isn’t even complete, it’s only about 63kB, the complete litchi apk file is about 152kB. That’s why it won’t even install on ANY android device.

1 Like

Thanks, Yordie - Good point on the APK issue… And, yes, to be clear I did complete the install process as outlined on the flylitchi.com website (install through Amazon.) The version shown in my original (edited) post was Google, but that’s just one of the two versions I attempted with the same result. (Had I realized there was a distinction between the two versions, I would have posted both.)

At this point, I’m just going to keep an eye on the forum, and if a solution is found, I’ll probably attempt it again (presumably through Amazon.) The application looks great, based on the videos I’ve seen - but it’s frustrating that I can’t make it work on my device!

1 Like

Jay - it works for me:

Android 7.1.2
SC version: v01.01.0064
litchi v4.19.0-a
I woiuld try checking with DJI to see if your recent update to SC blocks thiis.

Sorry for the dead thread revival, but I wanted to thank Steve for the advice. I was not crazy about the idea of factory resetting my SC, but I finally did it, then installed Litchi via Amazon, and it’s working. Thanks everyone for your help and especially Steve!

1 Like

Is there any way to download the app without buying it a second time? Already purchased it once for use with my android and to have to pay for the same app a second time seems… redundant.

@Jason_DeMark Concerning Litchi, unless you bought the Google version of android and want to download to a smart controller or use a DJI monitor (which requires the Amazon version and a different license than Google) then you can download to as many devices as you want as long as you use the same account for each download.

2 Likes