Litchi no longer links to my drone

It appears that the issue with the firmware update on my Air 2 S has been solved. As a result, I attempted to fly a mission the other day and now Litchi doesn’t link to or recognize my drone. I had to download a file from Litchi and then upload on the Maven app to fly the mission. Can anyone tell me how to re-sync my drone to the Litchi app?

Hello Robert, does the drone connect with the Fly app? You might check the User Guide for connection to Litchi if there are any basic questions. In SETTINGS, under “General” you should see “Sync Local Missions” and “Check and Sync License”.
Tap these also if the normal connection procedures don’t work. Good luck!

Connecting Litchi to your drone

First, ensure you are using the latest DJI firmwares on both your drone and remote controller if you are using one. You can update the firmware using DJI Fly/Go, or for older drone models download them from dji.com. Then, depending on your mobile platform, follow the steps below.

Android

To connect using a cable (Mini, Air, Mavic, Phantom 3 Adv/Pro, Phantom 4 and Inspire series), follow these steps:

  1. Make sure no DJI-based apps (including DJI Fly, DJI Go and other third party apps) are running in the background. If there are any, close them
  2. If you have another app (such as DJI Fly or DJI Go) set as the default app to launch when you connect the remote controller, you will need to clear the defaults for that app: go to mobile device Settings - Apps - DJI Go (or other app name) - Clear Defaults. Some devices automatically set the app you start as default, so this step may have to be done every time you want to switch app (for example from DJI Fly to Litchi and vice versa)
  3. Start your drone and remote controller, and let them initialize for a few seconds
  4. Connect the remote controller to the mobile device. For Mavic drones, you can use either the bottom or side USB ports, however make sure to use only one port at once (if 2 cables are plugged in the remote controller, Litchi won’t be able to connect)
  5. You will see a popup asking which app to start, select Litchi in the popup to initiate connection

Info Watch a video tutorial for USB connection.

To connect using Wi-Fi (Phantom 3 Standard/4K, Spark), follow these steps:

  1. Make sure no DJI-based apps (including DJI Go and other third party apps) are running in the background. If there are any, close them
  2. Force stop all DJI-based apps (including DJI Go and other third party apps). Please note step 1 is not enough. To force stop an app, go to your mobile device Settings - Apps - DJI Go (or other app name) - Force stop
  3. Start your drone and remote controller if you are using one, and let them initialize for a few seconds
  4. Connect to the Wi-Fi network of the drone
  5. Start Litchi

iOS

  1. Make sure no DJI-based apps (including DJI Fly, DJI Go and other third party apps) are running in the background. If there are any, close them
  2. Start your drone and remote controller if you are using one, and let them initialize for a few seconds
  3. Connect the remote controller to the mobile device using a cable. For Wi-Fi based drones (Phantom 3 Standard/4K or Spark), connect to the Wi-Fi network of the drone instead
  4. Start Litchi

Yes, firmwre is up to date on the drone and I am able to fly on DJI Fly App as well as the Maven App. I have never had to go through steps for Litchi to connect to my drone before. I will review the User Manual and see if there is something I can do there to get Litchi and my drone synced again. I always close out the DJI Fly App and any other drone Apps before attempting to fly with Litchi. Thank you for the response and feedback. Historically, I have never had problems with the Litchi App until my last firmware update.

1 Like

As a follow-up to my last post, I reconfirmed that I had the latest updates from DJI and went through the steps in the User Guide to connect to my iPad Mini which is the same device that I have always run DJI Fly, Litchi and Maven on. DJI and Maven set up fine and connected with my drone. Litchi did not. I confirmed also that I was signed into the Litchi App, which I was. As a last resort, with the controller active and the drone on, I shut down my iPad and restarted it. This did allow for a connection to the Litchi App. I was in my living room so I did not attempt a flight, but everything looked good and ready to go. Not sure why a restart of my iPad was necessary but it did allow for the connection. Hopefully this information may help another user if they are ever faced with the same dilemma in the future. At this point, I consider this issue closed. Thank you again for any feedback and suggestions that were made.

1 Like