Litchi Mission Hub Saved Flights Listing Menu Inaccessible

On occasion over the past years, the Ltichi Mission Hub saved flight listing becomes temporarily inaccessible no matter how many times the screen is refreshed, and this has again been the case between November 27th, 2023, and today December 1st, 2023, with no respite in sight just yet.

Since this issue normally resolves itself after a couple of days, I usually don’t make mention of it in this forum, but I decided to bring up the subject this time around because the locked saved flights menu has remained that way for an unusually long duration.

Is anyone else out there experiencing this same issue at the moment? Also, if any Litchi staff are reading this topic, I would be grateful if they could be kind enough to shed some light on how soon we can expect to see Mission Hub’s full waypoint flight planning and saved flight plan retrieval functionality restored.

No problems with it here. Google Chrome and Firefox both work

1 Like

This reply is appreciated. I will try another browser now.

1 Like

I doubt this is a browser issue. The flight listing page would be doing a database query. You didn’t mention it so I have to ask: Are you logged in on the Mission Hub page? If you weren’t, that would explain why you don’t see any missions. Are your missions available from the Litchi app?

Thanks for this reply, Wes. I was logged in each time I attempted to access my list of saved flights, but all I would get was a blank page in the drop-down menu of saved flights. I have seen this happen for brief periods in the past, but never for this long of a time.

I will look into finding a way of saving all my missions on my hard drive so that I can hopefully reload them if there occurs some cataclysmic data erasure in the cloud, even though that has never happened thus far.

Hmm, things have progressed from bad to worse now. After nearly a week of being unable to access my Litchi Mission Hum saved flights, I decided to log out and back into Mission Hub. That idea turned out to be a very bad one in that the same password that I’d saved for the Litchi Mission Hub no longer worked, effectively locking me out of my own Mission Hub accounts and all the saved flights that I spent many hours creating.

To compound the predicament, I can find no means to directly communicate with Litchi to explain what has happened. Over the past few years of using Litchi I have never encountered this type of lockout and in the absence of any email link to explain this strange impasse to Litchi, I decided to write here in this forum in the hopes that a Litchi staff member might be able to shed some light on why my Litchi Mission Hub account is no longer accessible.

In desperation, I even tried to uninstall and reinstall the Mission Hub but then I found that Litchi Mission Hub doesn’t even appear in my computer control panel’s list of programs, meaning I could not perform the uninstall. Any thoughts on how to resolve this issue would be enormously appreciated.

Well, I’ll be dipped. I just logged into my other laptop and there, like a shimmering mirage along a mid-July highway, lay all my cherished Litchi Mission flight plans, safe and intact as though their initial disappearance was nothing but a bad dream conjured out of pure angst.

I can therefore declare the State of Emergency to be officially over, and the National Guard is hereby directed to stand down. Had I scaled a desolate wintry peak to consult an oracle about this mysterious interruption of Litchi’s connectivity on two of my devices, the wizened one would probably remind me that it is better to have Litchi on a single device out of three, than to have lost Litchi altogether. I can therefore attest that the planets have resumed their respective orbital trajectories thereby balancing out the Karma Equation to assure my peace of mind once again.

God bless America!


please let us know which browser you use and its version too so we can try to reproduce the issue of missions not loading. did you try to log out and log back in? as well try to clear your browser cache if the problem happens again

the support email is

1 Like

This response is appreciated, Nico. Google Chrome is the browser I use most of the time while reverting to Mozilla Firefox on rare occasions. I logged out of Mission Hub but then found that my saved password was rejected, leaving me locked out of the account completely on my primary flight planning laptop. Litchi Mission Hub works normally on my backup laptop, oddly enough, with all saved flights appearing in the drop-down menu.

I’ll look up the version number of this Google Chrome browser edition, I must mention I did consider using the lost password option to reset the password but then chose not to take that step in case I then found myself logged out of the sole laptop on which my Mission Hub saved flight listing still appears.

Suddenly, this Friday, December 8th morning, my Litchi Mission Hub account accepted my previously saved password that had been rejected for about a week ending this morning. I tip my hat to Litchi’s Code Meisters for resolving this minor problem. Once again, I can retrieve and edit all my saved flights that took many hours to create in Lithi Mission Hub.

This week-long connectivity interruption got me wondering whether it might be possible to save copies of my listed Litchi Mission Hub flight plans on my computer as a backup just in case my tenuous link to the Litchi Cloud is again compromised by passing TicTac UFO crews who probably frown at us pesky drone hobbyists crowding precious airspace.