Litchi mission hub - how can I set home manually?

Data:
DJI-Mini-SE - iPad mini for Litchi app - Windows 10 on PC

My problem is HOME is not correct when I start Litchi Hub on my PC.
How can I correct that?

You do not set a home point in Mission Hub.
If the Hub loads in a different place than where you actually are, it is a result of the browser not able to get a correct location from your computer.

You might want to look at the location settings on your PC. I’m curious, when you go to maps.google.com in your browser, does it show your correct location? If not, how far off is it?

Using mission hub on my PC no ‘home’ point is shown but the map opens close to where I live (as my PC sees it). As I’m not usually planning a mission to fly over my house or immediate area I use the search box near the top left of the map to find the location where I am going to fly (or else just drag the map). I then plan the mission and save it ready to load into the Litchi app before I take off. When I get to the flying destination I always take off and let the drone record it’s home point which I try to keep as close as I can to the first waypoint. So far no problems doing it that way. :slightly_smiling_face:

Thank you for all the advises. Now I understand “why”…
I have now changed my browser setting to be correct and that works. :slight_smile:

Thank you, that a good idea when taking off is not from home.