Litchi keeps crashing at startup when I plug the RC of my DJI Mini 2

Hi there. I’ve just bought Litchi for Android for my DJI Mini 2 but I can’t get it to work. The application starts and grabs my correct location trough the GPS. But whenever I connect the RC via the USB cable, I select Litchi app to use with the newly connected device and shortly after Litchi crashes before connecting to the RC/drone.

I’m using Litchi app: 4.26.7-g, DJY FLY app: 1.13.2, Drone firmware: 01.07.0200, RC firmware: 04.11.0400. My phone is a Xiaomi Redmi Note 5 as up-to-date as it can be (Android 9 PKQ1.180904.001

With the exact same configuration, DJI Fly works fine. I’ve just reinstalled both apps to their latest versions, have updated all the firmwares through DJI Fly, have restarted my phone but the symptoms remain the same.

I’m looking forward to any advice that could make it work. Thanks in advance,


Make sure you’ve force stopped DJI Fly

Thanks Martin. I’ve done that too, unsuccessfully. I’ve even tried just now to start DJI Fly (its automatic startup is disabled by default), then force stop it, then start Litchi, switch on the drone & the RC, wait for 10s, plug the RC. Litchi crashed like each time

Follow the instructions from the Online User Guide:

1 Like

Thanks TriBar but that’s exactly what I did. And the app crashes whenever I connect the RC to the mobile. No instance of DJI Fly is running, RC and drone are connected together, both with the latest firmware. Is there any way to contact Litchi official support?

No you did not.

First connect the RC & Mobile, THEN run litchi.

Quote from the User Guide:

“4. Connect the remote controller to the mobile device. For Mavic drones, you can use either the bottom or side USB ports, however make sure to use only one port at once (if 2 cables are plugged in the remote controller, Litchi won’t be able to connect)
5. You will see a popup asking which app to start, select Litchi in the popup to initiate connection”

As I mentioned that’s what I did. I did not mention it in my previous posts but I do see each time the pop-up window. When I use Dji Fly and chose Dji Fly it works. When I use Litchi and chose Litchi, the app crashes after a few seconds. Each time

Try clearing the Cache and/or Data from Litchi.


Still the same: deleted Litchi cache & data. Force stopped all applications. Swiched on the drone then the RC. Waited for 10s. Plugged the RC to the phone. Clicked on Litchi to use with the USB device. Litchi starts, asks for authorizations (location, audio/video etc…) which I accepted all, the welcome screen appeared for 5s and then Litchi crashed. Before that I had also deinstalled/reinstalled both DJI Fly and Litchi. I’m getting desperate :frowning:

I have the more or less same problem. I did exactly the same as you did but my app doesn’t crash, it simply shows the error message that the multicopter is not connected to the remote controller. As a result I do not see the camera’s picture. I also do not see the number of satellites connected (or if at all available).

Hi Rainer. In your case it looks like the RC is not connected to the drone. Does it work well when you turn them on and use DJI Fly instead of Litchi? And also when you switch on the RC and the drone, does the flashing light at the back of the drone turn green after a few seconds showing it connects to the RC? Also the lights on the RC stop flashing when the drone connects to the RC.

Ok, problem solved :slight_smile: I did a few things and I have no idea which one did the trick. After making sure the drone and RC were up-to-date with their firmware, I have completely de-installed DJI Fly and Litchi. Did a cache / storage cleanup from system tools. Rebooted the phone. Reinstalled Litchi only. Started it, accepted all authorizations, connected to my litchi account. Then I closed completely Litchi. In the system settings for Litchi, I authorized full screen mode and turned off completely the battery saver. I switched on the drone and the RC. After they connected to each other, I plugged the RC USB cable to the phone and… it worked ! Now I can start to play…

Here’s the method i use

  1. Turn on Drone
  2. with the phone mounted and plugged into controller turn the phone on and wait for it to full boot
  3. Turn on Controller
  4. Choose the app I want to fly with (DJI Fly, Dronelink, Litchi, Rainbow Pro)

From what I’ve read and done the sequence should be:

  1. Turn on drone and remote controller
  2. Wait until they connect to each other (green light blinking at the back of the drone)
  3. Plug the controller to the phone
  4. Select Litchi on the popup window asking which app to use with the USB device
    This should startup Litchi and let it establish the connexion
    Now in my case I’ve changed other settings, not sure which combination made the thing work (full screen enabled, no battery saver for Litchi). And I have removed completely DJI Fly (I’ll have to reinstall it for future firmware upgrades). Good luck

The method I posted above works flawlessly

1 Like

Oups, sorry Marrtin. That makes 2 working methods then :slight_smile:

1 Like

@all a quick update: after the successful initial setup as described in a previous post , I have reinstalled DJY Fly. Now it works wells in any order, switching from DJI Fly to Litchi without any particular issue (after stopping the application). So it seems that it’s the initial connection that is the most sensitive to outside interference. Once you get through that initial step it’s pretty straightforward

Sounds like a phone specific issue, i have Litchi on three samsung phones and a Nokia G42 all with every other DJI app as well as one of them with the Phantom 2 version of litchi and have no issues when I installed Litchi on any of them.

I turn on the drone and controller and then plug in the phone, on any of them i can have DJI fly running at the same time with no issues

@J_Slater, agreed. I have a 5 year old Xiaomi Redmi Note 5, it probably doesn’t help. Anyway after a complicated initial setup now everything works fine

Make sure that you’re using a USB data cable and not the USB charging cable. There IS a difference.

1 Like