Litchi doesn't work

I bought this product but it doesn’t work on both the parameters I particularly wanted. Tracking and Folllow me. When tracking is selected it just goes into a weird mode of the drone jumping and twisting in the air with no control until tracking is switched off. Follow me just sits in the one position and when I move off with the controller it just announces lost and doesn’t move to follow. As I said unless there is some fix then its been a waste of money. I’m using a Samsung Galaxy A5.
I have reset the compass in both the phone and drone.

What brand of drone are you using?

DJI Mini 2 I’ve been using it for around 3 months and wanted to further enjoy the options with Litchi but to no avail

I might add that when trying to use follow me the split screen on the phone shows myself and the drone with me moving across the view and then out of it but the drone doesn’t follow so the app is follow me on the screen but not the drone

Your phone is pretty weak. Also with mini 2 there are some problems in the “track” mode on different firmware

I’ve played around with resetting the compass on my phone and the Follow me option seems to be working well now, thankfully, however it must be a firmware issue with the tracking as the drone goes into a wild state when tracking is on. It’s ok when you select ‘Tracking’ but the moment you draw the green rectangle on the screen the drone start jumping all over the place. The motors on the drone are revving up then slowing again while the tracking is activated.

I have a dji spark, and with the new version 4.22 and above, with the remote control, I see the same crazy twitching of the drone, but when I turn off the remote control and control it from my smartphone, the drone tracks normally. I think the developers are changing something in the algorithm and this introduces new bugs into the work of litchi.

I have same problem with Tracking with my Mavic Air 2. I tried on 2 phones, it just keeps bouncing and yawing left to right and you can hear that the motors are struggling to keep it in the air. Scary!

This video was made entirely in “track” mode. Without remote control.

Hi
What do you mean by not using the remote control and only on the phone ?

Dji spark can be controlled:

  1. Without phone and remote control.
  2. From phone via wifi
  3. From the phone, but using the gamepad.
  4. From the remote control via ocusinc. the phone can be connected to the remote control in two ways via WIFI and via a micro-usb cable.

I often use 2 and 3

In this video, I had to use the “track” mode, because magic leash refused to work on version 4.21.

If I read correctly the OP has a mini 2, which you need the remote connected to a phone via the lead to control it, and from experience both modes work fine, I suspect they need a more powerful phone, I use either an LG V50, Galaxy fold Z2, or a Galaxy tab 7fe with my mini 2

2 Likes

The issue described is happening to me too but with an Air 2, I tried the Samsung A50 and the Google Pixel 4, same problem. My friend flies the Mini 2 with the Samsung A40, and doesn’t have this issue.
Strange…

Yes, this problem now pops up every time. I don’t remember such problem on 4.17, 4.18, 4.19 and 4.20. It all started with version 4.21.

I strongly suggest viewing this guy on YT https://youtube.com/c/GAVINHR
He is always spot on in my experience. His vids on Litchi are excellent.

1 Like

I’m subscribed to him and watch him already. Yes, he does great videos :slight_smile: