Litchi Bug with DJI RC Pro?

I just purchased RC Pro to fly my Mavic Air 2S. I read that Litchi was compatible when installed from the Amazon app store. It downloaded and installed ok and my missions were available also.
This morning I flew using Litchi in FPV, and noticed the drone moves up about one foot when pushing forward on the right stick. It stops the climb and moves forward as expected.
I was puzzled by this and tried using the DJI fly app and it doesn’t move up first. Is this a known bug? If not how should I report it?
PS I don’t have the DJI Fly app start at startup, I usually use Litchi, so it didn’t need to be force stopped.
Comments are appreciated, I’ll be flying using missions later this week, but I expect they will work ok.

Hi Steve.
Did you then solve the problem? if it was a problem. I am also waiting for the rc pro, it should arrive tomorrow and I would like to dump lychees on it too.
Thank you.

No, but more flying I noticed the DJI Fly app does this also. It happens when low to the ground, so it may be the obstacle avoidance kicking in.

ah, ok. Thanks for info.

Hi Steve. Reading your post more carefully, something occurred to me, did you try to switch obstacle avoidance mode to brake mode? try and let me know because almost certainly this is it. Also yesterday I downloaded litchi sul’rc pro and paired with air2 s, but I still have to do missions.

Hi, I was thinking the same, since it happens low to the ground. It’s not a big deal unless I’m recording video real low. Thanks Steve

1 Like

Steve, unfortunately for me it does not work on rc pro with air 2 s, the connection between the remote control and the drone is intermittent, it disconnects and reconnects continuously, every 3/4 seconds. what fw version do you have on the air 2s? and which one on the RC pro?

Samething here,

connect disconnect, battery display 0% and sometimes the correct voltage.

Not safe to fly and not safe to sale.

RC Pro and Air 2S

Force stop DJI Fly then it will work just fine. More info at DJI Monitors (Smart Controller, CrystalSky, Phantom 4 Screens) - Litchi

" 6. You’re now ready to use Litchi on your DJI monitor! For the best experience, it is recommended (required for RC Pro) to force stop the DJI Fly/Go app before starting Litchi. To force stop DJI Fly/Go, go to the device Settings - Apps - DJI Fly/Go - Force Stop"


Force stop the DJI FLY app seems to fix the problem.

TY for the advice!

It worked very well. Thanks.

And one more tip: Always change your frequency band to 5.8. It will fly flawlessly.

Thanks Vico this worked perfectly. Is it necessary to Force Stop DJI Fly/ Go every time you want to fly using Litchi??

Same with me. But Force stop DJI Fly/Go fixed it. Thanks to Vico.