Litchi app not working with latest DJI firmware update 1.04.0000

I, unfortunately, updated to the new DJI firmware version 1.04.0000 3 days ago on my Mini2 (using IOS) and now I can’t get Track mode or Follow mode to work at all. When i tried the follow mode, the drone suddenly rose up and took off like a bat out of hell! i stopped it and returned it to home. Any way to revert back to the last firmware version? Is anyone else experiencing this problem? Thanks Duane

According to drone-hacks it is not possible to roll back your new firmware.

1 Like

Wow! That’s really sad! How does one fix this problem other than with an axe? Sad as it was working so great before I updated! Hope DJI or Litchi will have a fix!

Didn’t need to update the firmware

The system said it was available. Hindsight is 20/20! Wish I could go back in a time machine but can’t!

.I turned those notifications off a long time ago. They always make it worse

1 Like

I will for the future!

Well I’ve just been down my local field to check this out with my mini 2 and my Samsung Galaxy tab s7 fe, and had no problems in either mode,

Excellent! I went back and tested again and it did work. I think I had the controller in CINE mode which prevented it from working. Today, I had it in NORMAL mode and it worked great!

1 Like

Glad to hear you got it sorted👍

Thanks Martin!! I should have known it was operator error!! So happy it’s working!!

1 Like