Litchi app not connecting

I had one flight with Litchi app using my Galaxy S22 phone and DJI Mini SE drone. I lost FPV during the fligt. I believe I had DJI Fly app running in the backgorund, I guess it might have caused the issue. Anyway, now when I want to fly, Litchi app is not connecting. When I connect the remote controller to the phone, Litchi app is not starting automatically. If I launch the Litchi app manually it does not connect either.

I unistallled DJI Fly app and tried again but it did not connect again (cleared the cache / restarted the phone). I unisntalled Litchi app and installed it again but no luck. Batteries are fully charged (I tried with different batteries) and I believe the remote controller FW is up to date (at least I did not see any update notifications when I was able to connect). Any recommendations? Thanks.

PS: After all these attempts, what I tried further is, I used my wife`s Iphone and got connected to the drone using DJI app. This time it locked the motors an gave error code 8012 (there is no flight restricton at all where I want to fly). Before trying with the Iphone, I was able to start the motors using the remote controller without connecting it to any mobile phone.

It sounds like you have tried almost everything except a different cable between your Galaxy phone and the controller. Give that a try and always make sure that DJI Fly is force-closed.

1 Like

Thanks for the reply. It looks like it got locked because I wanted to fly in another country. When I got connected to a network, it updated its database and I had a successful flight using Iphone. I did’nt try Litchi on my Galaxy S22 yet, but I guess that the main issue was the need to update the database after change of country.

Going to another country should not cause connection problems between your phone and the controller but I’m glad you got it working.