Litchi App fails to open

Hi all, was flying and using my MM2 with the “new” beta version of litchi on my Samsung tablet. Everything was working fine, after not using it for some time I now find the App opens and immediately closes with just the briefest glimpse of the screen. The App detected it was closing and I believe it sent a report to developers? This included my tablet version etc. I have had no feedback for a week. I did check to see if there was an update to App but didn’t find one. Appreciate any help please…

Try downloading Litchi 4.25.0 from

1 Like

Hi there, downloaded apk file as suggested… however it fails to fully install. I uninstalled the Litchi app completely and then re installed it. When opened I’m greeted with my sign in page which promptly closes before I have time to complete! Tried the apk file again after Litchi re load but still the same…

Thanks, it work here ! (-:
(Samsung Galaxy J6, android 10, kernel 3.18.140, DJI Mavic mini 1)

  1. litchi 4.26 failed to launch after 6 month without using it env.
  2. uninstall litchi from playstore
  3. download & install 4.25.0 apk from link above
  4. go to playstore and disable “auto update” for litchi app
  5. fly my drone again
1 Like

That Worked! Appreciated. Thanks.