Litchi and no fly zones

I’ve been getting permission to fly in an authorisation zone locally and using the DJI Fly app which prompts me to confirm and agree to rules etc pre flight. How does this work using the litchi app. If I pre plan a flight for this area will Litchi also prompt me or do I have to set something up in litchi first.


1 Like

I may be wrong on this but I suspect that Litchi leaves flight restriction matters to the judicious discretion of individual drone operators, in contrast with the paternalistic collar and leash approach deployed by DJI Go and DJI Fly to the silent dismay of many.


@Jerbear ,
Here are a couple of topics on that subject.



Sam_G is right on target with his second reference.

One more task I always perform after using the DJI Fly app to unlock the authorization zone is to kill the DJI Fly app before starting Litchi.

1 Like

I’ve been chatting with DJI support regarding my Air2s, no fly zones, the DJI app and authorisation zones because I was having issues using the DJI Fly app even after getting authorisation. They have now created an authorisation for me which will last for 1 year. But here’s the problem. Litchi does not recognize the authorisation. I ran up the DJI app and loaded the authorisation they created for me and it was confirmed that it was uploaded to the drone. Closed the DJI App and ran up Litchi and loaded my flight plan which started outside of the authorisation zone and ended inside the A.Zone. However, once it reached the A.Zone it refused to go any further. Now some might say don’t close the DJI App. Leave it running in the background.! Nope! Can’t do that either. I had gone to a local football pitch and tried keeping the DJI App open while asking Litchi to fly a mission. The drone took off and hovered at the default 2/3 meter height as set in the DJI Fly app and would not even attempt to fly the mission. So can we now assume that when it comes to no fly zones or authorisation zones Litchi is not the app to use. Or maybe someone else knows another way round this problem.

Yes : apply to No Limit Dronez.

I do the following process which has worked for me:
(1) On a PC, I go to - DJI FlySafe, and make sure I’m logged in with my DJI account. Then I select “New Unlock Request” and follow the instructions. Basically you select a zone you want to unlock, enter your drone info, pilot info, reason for flying and the date you want to fly. Authorization seems to be automatic, and you are presented with a list of authorizations, with the new one on top.
(2) I then connect my drone to the RC and open the DJI Fly app. I hit the < icon in the upper left corner until I see “Profile” on the bottom of the screen, select it, and scroll down the right side of the screen until I see “Settings”. I select Settings, then scroll down the left side of the screen and select "Unlock GEO Zone. You should see the authorization you created in step one. Hit “Import to Aircraft”.
(3) Hit the < icon (upper left of screen) until you see “Go Fly”. I make a test hover at this point in DJI Fly.
(4) I then close DJI Fly and open Litchi and make a test hover to verify I’m good to go.
Hope this helps. I have used this on my iPhone and my son has used this on Android.

Did all of that numerous times and eventually gave up. I use DJI fly now when it comes to authorisation zones…

One nuance on Step (4): to truly close an app running on an iPhone, just swiping up on an open app does NOT close it. Rather it just puts it in the background still running. You must swipe up to mid screen, release it, and miniature versions of all open apps appear. Place finger on the still-open DJI Fly icon and swipe IT up.

If your on Android 14, you cant open the DJI Fly app, there for cant update, cant acquire the unlocked zones made on DJI unlock site.

This app would be great if it was standalone. But its completely dependent on the Fly app in many situations. I downloaded the app connected real easy, but cant take off because i cant import the unlock licenses (android 14)

The Litchi app extends the capabilities of your drone over what can be done using DJI Fly (or Go). However, it is not a total replacement for the DJI app and some functions are not implemented in Litchi. This is often due to one of two reasons:

  1. The DJI SDK upon which Litchi is built does not provide a software interface for the function you desire.
  2. The Litchi development team has simply not incorporated the function you desire in the Litchi app due to other priorities.

What refunds are you referring to?

Rr1. Why does that matter? He’s on here to help and from what I see he does that pretty well. Maybe I’m wrong, and if I am I apologise, but your response is coming across a little rude.

1 Like

Here is a list of functions for which the DJI software is required because they are not implemented in Litchi.