Latest Beta issue: No compass calibration

Dear developers,

tried version v4.23.0_BETA-g Build 30004215 for the first time today.

After some flights without any issues, I got a compass calibration warning.
But when I wanted to calibrate the compass, nothing happened.

I opened the settings, clicked “compass calibration”, then an info window appeared.

After clicking “ok” in this info window, nothing happened. I restarted Litchi several times without success. At the end I had to calibrate the compass with DJI Fly.

In former versions, compass calibration worked perfectly.

It would be nice, if you could fix this, because it is IMO an important feature.

Thank you very much!

Best regards and have a nice week.

Hans

1 Like

Hi Hans,
Compass calibration works just fine.
You wont see any instructions onscreen however, only verbal instructions.
You also can tell by the light/LED on the drone itself.

Hi TriBar,

I will recheck, but sadly there were no audible instructions. And no LED signs (as far as I saw).
In former versions I heard Litchi telling what to do, but today nothing was heard.

However, to avoid any misinformations by me, I will recheck and call again.

Thanks for the help.

Best

Hans

Rechecked! Everything is ok. Accidently I touched one of the volume buttons unseeen against the remote controller, so that the sound was muted.

Everything is working ok, sorry for the false alarm. My fault!

May I besides ask another question (it has nothing to do with this issue):

I would like to pair 2 remote controllers with 1 Mavic Mini. How can I pair only the controllers, without changing the drone? Is this possible, or do both exchange individual keypairs on both sides?

I asked DJI for it, but they gave me no correct answer.

Best

Hans

Did you know that the message “compass calibration” will show every time you put the drone near metal objects. And every time it will disappear if you remove the drone from this place. Thus, there is no need to do calibration.

For example, if you get into a car, you will immediately receive a message about compass calibration, you just need to get out of the car

This has always worked with sound only in all versions

I know this, because I have a magnetic bse for my hamradio antenna on my car, and when far away from it, the compass calibration is not needed.

But this time I was in the garden of my house, so there was no magnetic field around (as far as I know). However, the last starting point was some miles away.

But this does not matter, the reason was just: the sound was muted! So I was irritated, as I heard nothing and (of course), Litchi got no optical feedback (which is of course not necessary, when there is sound).

Best

Hans

And it still does! No need to worry.

You can’t pair 2 controllers simultaneously to the Mavic Mini.
As far as I know the only drones that have this possibility are the Mavic Pro and Inspire series.

What I want is, use 1 controller and fly. If its battery is low, I want just to take another controller and fly more. Not using them the same time.

Of course it will work, when I am pairing each controller after each change. But this I wanted to avoid. As far as I know, the controllers are using the same presharedkey (I can telnet to the controller, it is just a linux system and there is a wifi.conf with the PSK in it.

Still do not know, which is the “server” and which one is the “client”, but in fact, the drone is of course just a flying “hotspot”.

However, it is not important, if you do not know exactly, no problem. I can just pair before a change to the other controller, it lasts below a minute.

Best regards

Hans

What you want is clear to me, but it still requires 2 remotes paired simultaneously.

Hello. Isn’t the remote control battery enough for 3 dji mini batteries?

1 Like

Akku power is enough for 3 batteries. The reason is another one. I have two controllers. One is left origininal. The other one got two antenna connectors, so that I can change antennas.

This one is for testing purposes to increase range. At the moment I am using antennas with 14 dBi gain, which is a lot (almost 11 dB gain). I want also test other antennas. As I am a hamradio amateur, technics is interesting for me.

So I want to switch between both to compare the results.

Hope this explains it to you.

Best regards

Hans