Jerky gimbal control whilst using interpolate/waypoint missions

Hi guys.

I am problems with the gimbal jerking on my DJI Air2s whilst flying a waypoint mission with interpolation.

The link to the mission is here: Mission Hub - Litchi
The video link is here: https://vimeo.com/708021130/753f02e093

Have I used the settings correctly? I did not have this much gimbal jerk on the phantom 4. I am using litchi with my Samsung S9 and the Air2s standard remote controller (not the smart controller). The app is the most updated version.

I set this mission up by using the ‘Record waypoint at drone’ function, recording the heading, height, and gimbal pitch as I flew around the property. This footage is pretty unusable so wanting a fix. I can’t smooth this out with warp stabilizer with this much movement.

Thanks
Brayden

Hi, and welcome to the forum.

This behaviour is typical and ‘normal’ for newer DJI drones that use the DJI Fly App, and has been discussed many times on this forum.
Do a search on this forum for “jerky”.

Also have a look at this topic:

Hi Brayden.
The video is a bit more jerky than I’d expect for a Litchi/Air2S, but it is a small orbit. And that brings me to an alternate approach that you may have tried already. Use the DJI Fly app to run an orbit over the site. I’ve had very smooth results with my Air2S flying orbits as small as 20m radius that way.
By the way, the link to your mission didn’t work for me. It just took me to Mission Hub - Litchi and not to your mission.
Cheers, Greg.

Hi. Thank you for your response. Unfortunately after another test today, having an excellent remote signal has not helped at all and the waypoints are still terrible. The gimbal/heading of the drone is all over the show and this is certainly unusable at this point.

Do you have examples of people using Air2S missions successfully?
Did you review the mission link to ascertain whether it was correct?
Are there steps I can take to minimise the drone fritzing all over the place?

I would not call this a usable/viable function of litchi currently.

Thanks Greg - I will need to try that next time, however I don’t particularly want to rely on DJI for saving waypoints and would rather use litchi. If litchi does not support these drones however I may have no option

1 Like