iPhone hardware requirement for Litchi + Mini 2

Is there any iPhone hardware requirement/recommendation for the iOS version of Litchi when being used with a Mini 2 drone?

I’m trying to plan very simple waypoint missions to take just still photographs, and even though I think I have everything set as it should be, and have taken into account things like having Gimbal Pitch set to “Interpolate”, Heading Mode to “Custom (WD)” and Path Mode to “Straight Lines”, I’m seeing rather erratic behaviour… Namely no AEB, just single photos, and gimbal pitch ignored at the first waypoint. I can’t even take a bracket of photos manually when not flying a mission anymore, though this was working the other day when I first tried the app out.

What gives, then? Is it that my just over five year old, 1st Gen iPhone SE simply isn’t up to the task?! It works fine with the DJI Fly app, but then that is supremely basic compared to Litchi, of course.

Cheers

Mark

Litchi works just fine on an iPhone SE, the type of drone you use is irrelevant.

Which functions will or will not work depends on the type of drone you use.

AEB should work with the Mini2, at least in manual mode and manual panorama mode. (I never tried it in a waypoint mission).

Gimbal pitch ignored at first waypoint is normal interpolate behaviour:

From the Online User Guide:
For “Interpolate” to work, the previous or next waypoint need to be set to “Interpolate” as well. Litchi will then automatically adjust the gimbal pitch angle to start and end at the specified angles, and smoothly transition while travelling between the two waypoints.

Are you adding any delays before/after taking a photo, especially AEB? Things will choke up while waiting for it to write the data to the SD card and mess up all the other actions. If you did not, try adding 3 seconds after it takes the (each) photo. If it works, you can cut this down depending on your drone, SD card speed, etc. Try a quick mission doing this to see what happens.

Also, issues at the first waypoint seem to be a common thing. I have seen it recommended to add a waypoint before you want to take the first picture to get everything set up and ready.

Firstly, my most sincere apologies for not getting back to you both sooner… Thank you for replying to my post as quickly as you did, though, back in the day!

I did get it all to work ok on my ancient iPhone SE the next day, but I can’t help thinking it was struggling a little bit to keep up. When using that phone with DJI Fly a message was coming up every now and then saying the phone CPU was overloaded. It didn’t seem to actually affect anything, but not a good thing to be seeing and ignoring, of course. Long story short I got a new iPhone… I needed a new one anyway, and at the very least the larger/brighter screen will be worth it alone. You’re right, though, Litchi did seem to be working ok, basically, on my old 1st Gen SE.

AEB does seem to be working fine, now. I don’t think that was user-error, but it probably was!

I suppose it would be slightly more accurate to say that for “Interpolate” to work there simply has to be a “previous” point it can use, it’s now become clear. So…

I had been playing with delays, but I was messing around with different settings and it could well have been what you suggest, when my delays were in the wrong places. It was as if it sometimes worked, sometimes didn’t, but there must have been a reason. Whatever’s, sound advice and I’m doing exactly what you suggest. I’m setting delays before and after photo tasks and gradually reducing them, fiddling around, seeing what happens. All good so far.

Indeed, this is what I now do… I set a “gash” waypoint a few metres above the first usable one and take it from there. It would be great if the software just did that for you, in some way… I mean, not set a waypoint in a different place, but have something internal it can work from so it can set gimbal pitch correctly at the first waypoint. The drone knows “where” it needs to be for the first waypoint, why can’t it just set the gimbal pitch as well?

Not a big one and easily worked around, but one of those instances of one more little thing to do, EVERY time. Heigh-ho.

Thank you!

You can do the action at the first waypoint “stop” then “change the angle”

“You can do the action at the first waypoint “stop” then “change the angle””

That does not work in a ‘Curved Turns’ mission.

I read that the author of the article uses “straight lines”. Right here

Your comment seems redundant.

Hi paxxa

Ah, ok! I should have maybe spotted that is an option in the actions menu, right? Absolute beginner.

I’m going to go out in a bit and try my updated missions. At the moment I’ve set the first waypoint as:

Stay For 5s > Tilt Camera to “x” amount > Stay For 3s > Take Photo > Stay For 10s… On to the next waypoint.

Then every subsequent waypoint is the same, apart from the second and third actions are removed… All other settings are as I originally laid out, so including “Straight Lines”, yes.

I’m guessing I don’t need to have all those “Stay For” commands in there, but they’re handy at the moment just so I have a little time to be keeping an eye on things.

This should work, right? Any thoughts?

Yes, this should work. You can try the emulator before flying to see if it takes photos or not.

Nice one… Looking like problem solved. Cheers

Using my Mavic 2 Pro I have always been able to get AEB. But now even when I manually switch to AEB raw which he flips best single shot. What is the fix for that?

Either magic, or what @George_Kasdorf suggested sorted it for me (though my drone is a Mini 2, of course):

“Are you adding any delays before/after taking a photo, especially AEB? Things will choke up while waiting for it to write the data to the SD card and mess up all the other actions. If you did not, try adding 3 seconds after it takes the (each) photo. If it works, you can cut this down depending on your drone, SD card speed, etc. Try a quick mission doing this to see what happens.”