I have DJ2 Mini, before Litchi installed firmware updated fine. Now can't as Litchi takes over

I bought drone (DJ2 mini) had a couple of firmware updates early on. After installing (registered) Litchi it won’t run (DJ software on Android) thus I can’t check for any ‘latest firmware updates’ for the drone itself. How do I suppress Litchi to allow this by not UN-installing Litchi? I’m running Android 12.
ie Even if I select DJ2 app, Litchi always launches when Drone and handset turned on.

Open Settings on your device (Phone).
Go to Apps
Go to Litchi
Tap on Litchi
Tap on ‘Set as default’
Tap on ‘Clear defaults’

Now you can choose between apps at startup.
(be sure to also select ‘just once’.)


Thanks Yordie for the suggestion. I tried and it didn’t make any difference.
I tried clearing caches also for both apps.
The ‘solution’ I found was to reload DJI app.
However it seems for politics or ? the app is no longer on Google Play. (seems since 2021 according to some blogs)
After successfully downloading from DJI website, I was able to re-install the DJI Fly app and with that it was able to then do a firmware update as well Flysafe data update.
That done I’ll now use both DJI Fly and Litchi as I need when prompted which program (app) to load.
Thanks for your help.
PS the APK file from the DJI website is 1673425127704-DJI-v1.9.1-230105-1015-55180-official-sec.apk

Now that you’ve updated to the latest version of DJI fly, each time you open it, it will phone home and check for updates, both for firmware and also itself

Yes I was hoping it would!