How to use RTMP streaming in Litchi

where to get the RTMP address? to be input in litchi app?
What streaming software can receive the output from the app

You can use a youtube or twitch RTMP address to stream directly into there.
Or you can create your own RTMP server with nginx and redirect the feed into OBS.

3 Likes

To stream to youtube.com for example, you need the RTMP url and the stream key, then you input both in Litchi in this format URL/STREAM_KEY, here is an example below (your own rtmp url may be different):

rtmp://a.rtmp.youtube.com/live2/STREAM_KEY

You can get both url and key from youtube’s live studio

2 Likes

I noticed that at the moment in Litchi the quality of the encoder is noticeably worse than in RTMP in DJI Fly - the video turns out to be more pixelated and crumbly, as if strongly squeezed. I have a mavic mini and android 10. The wifi signal is 150mbps. I hope the developer will pay attention to this point.
The picture is more pixelated and crumbly already on the smartphone screen. (in comparison with Dji Fly)

sorry, in what input of the software you input the url address? i dont get it

Button #6 (SHARE VIDEO STREAM)

1 Like

thank you ! i was looking in the setting menu, not in this screen, sorry

fine, it works when I fly manually, but when you start from waypoint screen to fly a mission the share video stream doesnt appear, so, how can you stream a mission you are flying on line?

What version of litchi are you using?

Start streaming in FPV Mode, then switch to Waypoint Mode and start flying your mission.

Waypoint mode also has a broadcast start button

Post a screenshot to prove @Fernando_a is wrong with his statement there is not.

the version is 4.25.0

it doesnt, I cant find it

All right, I did it, when you finish your mission and go back to FPV the icon of sharing is not there anymore. You have to land, close the app and run it again to show again the sharing icon. Strange

Maybe you forgot to turn on the video mode

no, the video mode was aon

1 Like

I dont see this image, as told, the share icon is not visible in waypoint. what version of litchi are you running?

I don’t understand what you are asking

Screen_Recording_20220816-102506_Litchi_1