How to use different flight speeds during a mission?

I would like to do a fast flight (with a Phantom 4 Pro) out to the first waypoint, fly very slowly between the first and second waypoints, and then do a fast flight back home. I tried to set up such a mission in Litchi, but it flew at the high speed on all three legs.

In the Mission Settings, you can set the ‘Crusing Speed’. That will control the flight speed before you reach the first Waypoint.
Then, set the Speed for Waypoints as you want to for each one (from very slow to very fast). If you move the slider for the Waypoint Speed all the way to the left, it will go to ‘Cruising Speed’ which you would have already set.

Thanks for the suggestion. I tried something a little different from what you suggested: Assigned the same speed to all of the waypoints but one, which was set to a low speed. With those settings, it used the same speed along all of the legs. It seemed to just ignore the low speed setting on one of the legs. However, the estimated time for the mission increased when I decreased the speed along one leg, which made it seem that Litchi was interpreting the mission the way I hoped.

Its strange that it would ignore a different speed setting for a Waypoint. If you would like to share the mission, someone here will be happy to look at it and see what the problem might be.

Here’s how you do it:
In the Mission Hub:
-Mark your mission as NOT private.
-Copy the link in the adress bar of your browser, and paste it here.
Example: [https:/]

Mission Hub - Litchi

Plan waypoint missions from the comfort of your chair!

1 Like

Thanks, Sam. Someone on an old post at another forum mentioned that changes in flight speed don’t take effect if the drone is disconnected during the mission. Here is the URL:

Apparently the firmware of your drone doesn’t support it.

Read the July 2022 & November 2022 Updates:

Excellent research, Yordie. Thank you very much.

I see nothing wrong with your mission parameters. I scaled it down (to make it a shorter mission) and ran the VLM in Google Earth Pro and it functioned like I would expect it to.
To @Yordie’s point, what firmware versions are you running? Android or IOS Litchi?

Thanks to everyone for the suggestions. Based on the comments here and on another forum, it seems that changing the firmware might help. However, I’m going to leave well enough alone. Everything else is working fine. I don’t want to change the firmware and risk introducing new problems.