Horrendous MNUl Exposure Settings Bug (not sure if anyone else has mentioned this)

Yesterday I flew 4 flawless missions 2 530 exposures and 2 370 exposures with Mini 3 Pro and DJI RC Pro Controller. All the flights went well but as the light began dropping I wanted to lower the shutter speed (I always fly in manual mode when doing ortho mosaic photogrammetry}. I moved the shutter speed from 1200 to 800 and at 800 it always reverted to “Auto” and another issues was 800 was my last choice when allowing for more light with manual settings. So not only did it revert to auto but it also gave me no slower shutter speed passed 800. I sure hope this can be addressed or perhaps it’s just a hiccup on my controller. I do periodically reload the ver. 222 …this evening it once again switched to “Auto” at 800 but it did allow me to have lower shutter speed options before reverting to “Auto” shutter speed. If you shoot in manual shutter mode and want to see if it happens on your rig I’d be quite interested to hear about your results. I’ve got more flying again tomorrow so I’ll reload the software to see if that takes care of the issue.

No problem here.

I think you are confused and/or misread the screen:

  1. SS 1200 does NOT exist, SS 1250 does.
  2. Above SS 8000, NOT SS 800, the camera switches to Auto.
  3. You have to swipe UP for a lower SS.

See the 3 screenshots.

Many thanks for your response however If I was going the wrong way for the adjustment can you explain why when set initially at 1200 for the previous mission when I was readjusting it for next flight it went down first to 1000 and the next setting below was 800 where the problem occurred(that is what I flew at when 800 kept switching to Auto) ? I also had another anomaly which I forgot to mention. while on a mission the interface was somewhat too large (for RC Pro) without information being fully legible . There was a slight cut off around the interface edge of about a 16th of an inch. Another question I have is what is the purpose of a bolder Home Symbol (thick black H inside a circle) floating around the interface which on my screen was almost as much as 50% off the screen on top as it floated from corner to corner in the interface while I was flying and more visible when in the lower corners…is that something which indicated the drone’s orientation. I had not noticed that happening prior to yesterday. If I fly today I will try and get some screen captures of what I’m talking about. Thanks again for your comment. I’ve also reloaded the software for when I fly next.

Most likely you have “Augmented Reality” turned on. It displays the Home point in the video-feed in real time.

Have you read point #6 in the link below and acted on it?

I was able to recreate this bug and posted a short screenrecording on YouTube.
Litchi Pilot Build 222_Shutter Speed jumps to Auto in stead of 800

Yes I always make sure that “FORCE OFF” has been done to DJI App prior to flight that’s why other than the 800 to auto issue I had trouble free flying. Where can I read more about what “Augmented Reality” does? On a plus note with the Beta Pilot…I discovered something really good. With the existing Litchi App if you choose by mistake the wrong flight plan it will attempt to fly there regardless of how far away it is. I do multi flight plans for my larger missions and sometimes I choose the wrong second portion of the flight plan for the mission. I did that yesterday with Beta Pilot and it said it could not fly there…very nice. In the past with Litchi App I had to manually halt it once I realized it was not going the correct direction to where I wanted it to continue the mission. I’m pleased you were able to repeat the bug I reported yesterday…if I was at 8000 instead of 800 it would have immediately tremendously indicated an improper exposure on my screen whereas it gave me the difference on screen of an adjustment from 1200 to 1000 difference that’s how I knew I was correct with regard to what setting (800 not 8000) had been set.

That’s not true.
In the Litchi app the maximum distance between the home point and WP1 is 4000m, in Litchi Pilot it’s only 1000m.

I beg to differ…my experience was exactly the opposite and the alert on Pilot came before it starting flying wrong direction
at all while on Litchi it had flown quit far in the wrong direction before I noticed what was happening and never gave me any alert.

I predicate this on what I’ve actually experienced regardless of what you’ve stated to be the parameters….kind of like
our discussion about me trying to set it at 8000 VS the reality of me setting it at 800 shutter speed yesterday….

Do you think I should base my conclusion on reality or theory?

Can you point me in the direction of where I can learn what “augmented reality” is?

Thanks in Advance

I just saw wesbarris video of what Augmented Reality is…as a photojournalist I don’t manipulate reality. It was interesting but I won’t be using it since I primarily document environmental degradation and change with my ortho mosaic photogrammetry.

It’s all about reading comprehension.

Regarding reading…aside from where I read about my controller and the other numbered items along with that for other controllers where is there documentation which can be downloaded. I’m particularly interested in interface information for example the 48MG icon without that present I still get that file size with my DNG’s so what function does it allow to happen…does documentation exist or is it something which since it’s beta the developers reasoned things could change in a manner that anything like that would require constant updating…? Thanks to anyone who can lead me to where things are explained and or defined.

Litchi Pilot is still in Beta.
As a beta TESTER you should have a lot of experience with, and knowledge of the traditional Litchi app.

You could start with reading the Online User Guide:

You can use the search function on this forum.

1 Like

As I alluded to before I predicate what the program does by using it not reading about it…with the exception of the portion about my controller. Let me pose this to you…when you read my bug discovery post (which for whatever reason since July testing began no one had discovered). Did you believe what I stated or question it in a post? As I recall you questioned it before even attempting to see if it was true! Then upon your experience you discovered I was correct. I’ve beta tested numerous products and those in charge of the testing recommended the exact opposite of what you have to me…go out with the program and test test test don’t sit around and read documentation.Test what it says or test what you’re curious about…I’m really sorry if I’ve offended you in some manner but it almost seems like you’re responsible somehow for the code and take bug reports personally. Regarding reading I am thankful for your taking the time to have me read about what needs to be done in order for the program to work properly for launch and missions…I would have never been able to find that bug without you taking the time to tell me that. When this process of beta testing is over I would like to send some thoughts to someone further up the food chain with some ideas about how I think it could be improved…by the way the vast majority of endusers do not read the documentation this is a proven fact and an assumption on the part of the software creators when coding…it is also interesting to note that from my own experience when doing training for Adobe at publishing conventions the coders knew less about the actual use of the finished program…when one of the principle coders (not the Knoll Brothers) remarked to me after I demonstrated Photoshop “I did not know the program could do that”. So please don’t question the different ways beta testers work since their job is to do actual testing not reading.

Hi Michael,

Thank you for your input. I am sorry that some of the responses you have been given were not as considerate as they could have been. We do receive a lot of comments from those who blame the software instead of considering their own understanding of how it works. Still, that is no excuse.

You are correct in that many people do not read the manuals. Some may read them after discovering that the software is not functioning as expected. Some (many), just post their questions here.

Your comments about Photoshop are also interesting. I have been in charge of a large data collection system. While I knew everything about how it worked, I was always amazed watching the speed with which users used the applications that I created. They were much faster (better?) at using the software than I was even though I designed much of it.

If you find any other bugs, please continue to post them here.

Wes thanks for your very kind note and again for helping me get started with the testing by telling me about what I needed to do for launching and completing a mission. The whole time I was writing that note I felt it may be misunderstood. I’ve
enjoyed doing the testing very much and I look forward to it’s release and I will actively promote Litchi Pilot to others I know that do waypoint flying like this for a living. I’m also quite impressed with your “Augmented Reality” feature and it’s a pleasure for me to interact with its creator…I’m curious to know how you came up with such a great name for it. Thanks again for taking the time to read my last post…

Augmented reality is creeping into things we do on our phones and computers. I just felt is was an appropriate name.

:slight_smile: eing slightly Dyslexic, I find it hard to read and understand the above arguments…However, I have been a Litchi user for several years, and have happily and successfully used the IOS version from those years back.

Having thought (?) it would be a good idea to have a better camera than either the Mavik Air (1) or the DJI Mini 2, I have moved up the the Mini 3. I then found out that IOS had been dumped, so had to go for an Android (A54) phone to run Litchi.

The step change has given me a great learning curve of Litchi etc.

I have successfully completed a simple Litchi photo mosaic.

Feed back includes a very slow metres/second to the first waypoint, less than a m/s. Landing at the end of the mission seems to have varied on my two test runs. On the first run the drone landed or crash-landed very close to the take-off point.I was not convinced it was the drone’s fault, it may have been me. On the 2nd run, at the end of the mission, the drone just stopped midday. It was easy enough to bring it home with the control knobs…

Either way, I am now able to continue some work I do for a local Wildlife Charity.

So many thanks for this Beta version…:slight_smile: