Head tracking requires VR mode, requires gimbal stabilization?

DJI Mini 2.

Head tracking currently requires VR mode. Does VR mode require gimbal stabilization???

Seems VR mode should incorporate FPV mode. Why would VR mode stabilize the gimbal when the ONLY use is FPV? Or maybe I’m missing something…

What I’m getting now… Head tracking works vertically, up and down. But the gimbal is stabilized. Also, there is no head tracking left and right, and, alternatively, there is no flight control left and right.

Questions…

  1. Can gimbal stabilization be off while using head tracking?
  2. Can we look left and right in addition to up and down?
  3. Can the aircraft be directed left and right with head tracking?

Please tell how…

Seems the Mini 2 doesn’t allow the “Immersion” setting? Is that it?

Thanks!

I believe you are saying that the gimbal should be in FPV mode rather than Yaw Follow mode?
You should be able to change the gimbal to FPV mode in Litchi’s settings then change to VR mode and voila!

Mini 2’s gimbal cannot pan left/right. If you want your head movements to control the drone yaw then you need to use either Joystick or Immersive Aircraft Head Tracking modes.

1 Like

Anybody who does FPV knows what I’m talking about. We want the gimbal/camera to follow the movement of the drone. The view should tilt LEFT and RIGHT when the drone moves left and right. That means no stabilization.

Using Mini 2, Litchi v4.21.2-g.

Settings > Aircraft > Gimbal Mode FPV

Then switch to VR mode where that setting is “None”.

The gimbal is stabilized. The gimbal/camera does not tilt with the drone like in the default app’s FPV mode.

In FPV mode, the gimbal’s roll will mirror the right joystick’s movements (left/right, mode 2). For example, if you push the right joystick to the right, the gimbal will roll to the right accordingly.

Note that this will only work if the VR ‘Aircraft Head Tracking’ setting is set to ‘None’: Help - Litchi

The gimbal need not roll in either direction, it just needs to stay fixed (not stabilized).
It’s not doing that. The gimble is stabilized, it remains level with the horizon.
Anybody else notice??? I’m sure most people use the Mini 2 for video. I will ask around on YouTube too.

Are you not getting this behavior? Litchi should not change the gimbal mode when you enter VR mode, however make sure not to change the aircraft head tracking from none to something else or it will change the gimbal mode to Yaw Follow

It doesn’t work. Surely somebody else has experience. I will continue asking around on YouTube, too.

In my opinion, you should separate head tracking from VR mode so head tracking can be used simply by itself, with a single panel display (the whole phone screen instead of it being divided into 2 parts). Maybe that would make the FPV function easier to implement, too.

I tried the mini 2 gimbal fpv mode and it does not seem to work like it used to.
It seems DJI has changed how it works on newer drone models so it does not react to roll commands directly?
Also it appears that when Litchi controls the gimbal pitch (when Gimbal Head Tracking is on), then the gimbal is no longer in FPV mode. Did you try with all head tracking turned off?

Okay. Seems like it’s not Litchi’s fault.

The Litchi app FPV mode failed while NOT in VR mode, too.

The Fly app FPV mode worked.

So it’s not related to firmware.

Then I installed the most recent “battery firmware” and the recent DJI Fly app update. Now the Fly app FPV mode doesn’t work.

Apparently something in the Fly app changed that wrecked Fly app FPV mode, too.

I deleted the Fly app and re-downloaded it. FPV mode failed, so apparently they have already “updated” the Fly app download to include the FPV bug.

Maybe the reason DJI disabled FPV mode is so we will buy their FPV drone?

You don’t think it’s right to split litchi into litchi dji go4 and litchi dji fly.
For dji go4 users, too many errors may occur due to new models. And also the size of the program becomes larger and requires more smartphone resources.