Hard landings with Litchi app

Using already some months the Litchi app. About the possibility like follow me, etc,…. top!!! All working really fine. BUT… the big different between DJI app and the Litchi app, for me, is every time I go to land on the ground, it ended with a hard landing, while dji app is really very smooth… I hope somebody can help this out because it don’t feel good to see my MA2 falling always from about 10cm to the ground. I ‘never’ got that problem with the DJI app.

Turn on obstacle avoidance and precise landing in the settings

Where do I find this options, do I need to fly to see this settings? Because I just look for it but didn’t find it, drone was not flying.

Settings are like this… just got same issue, not a soft landing as the dji app and the last 5 m very very slow downwards while I Puch fully down do land.
Minimum Location accuracy need to be min 10m?

Almost all settings are stored in the drone itself, so in order read/change them your drone & remote controller must be turned on and connected to each other, also Litchi needs to be connected to the remote controller. There’s no need to actually fly your drone.

“last 5 m very very slow downwards while I Puch fully down do land.”
That’s because you have ‘Landing Protection’ turned On.
READ the User Manual of your drone !

“Minimum Location accuracy need to be min 10m?”
Only applies to ‘Follow Mode’.
READ Litchi’s Online User Guide !

The downward sensors (bottom of the aircraft) control the landing, in order to do so they have to be turned on (Beeld Positie System).
Obstacle avoidance & Precision Landing are of NO influence of your ‘problem’.

“my MA2 falling always from about 10cm to the ground.”
Most likely this is a ‘bug’ in the MA2’s SDK and nothing Litchi can do about it.

Thank you for the clear explanation.