GPS position failure

trying to use the application with dji mini2, I found that the positioning marks an error of approximately 10 meters away. which was not happening when I downloaded the app. now with these problems it is difficult to use the application to use it in any of its modes.

2 Likes

Camilo,
Are you saying that the home point is off 10 meters upon setting home point or after leaving home point and attempting to return to the same point?

Looks like you are inside with the connected smart device (Home point) where GPS reception is poor.
As long as the home point is not updated (audible) to the position of the aircraft, it will be the (faulty) position of the smart device.

my litchi behaves the same way. all mission points are also shifted by 5-10m

1 Like

Buildings usually outright block a direct path for signals from GPS satellites. Those buildings don’t absorb a lot of those signals and reflect much of it instead.

GPS receivers get their accuracies in part from the direct path between satellite TX and receiver RX antennas, and reflected signals are indirect (so longer, and that means delayed to the RX), so reflected signals contribute greatly to inaccuracies in calculated fixes. And, of course, the more satellite sources being reflected, the more confused the receiver will be. When you’re downtown and your GPS device is “jumping around” you’re seeing the effects of reflected GPS signals.

This is usually called the “Concrete Canyon” effect, and the exact same thing happens in natural canyons.

Why does my phone map me perfectly on the map.
And my quadcopter is 5m away from my position.

At the same time, I create a mission and the whole mission when the drone flies, as if shifted on the map by 5 meters to the south.

This problem has appeared recently. Previously missions were very accurate.

Here the same - with a Mini 2. I tried the waypoint mode some times, and the error is around 10m from the points of the map - this is crucial to solve, as drones can be lost to nearby obstacles, and our accuracys are bad for any type of job and map. If doing that with other app like Rainbow, did not find the same error on basically the same map. With so many here confirming the issue, there is no doubt it’s concrete and sound - not good at all. So, Litchi must address this problem ASAP - almost seem to be a datum error, but you guys will have to find the reason this terrible fault is happening ok! Thank you very much in advance and greetings to everyone.