Gimble points down after leaving 1 st waypoint, Program shows 0 degrees the camera is -90 If POI is deleted the gimble works

at each waypoint the gimble shows correct based on POI The Virtual mode works right just not when flying DJI Air2 s Using latest firmware Mission Hub - Litchi (

Welcome to the forum.

If I understand your description of the problem correctly, the Mission Hub shows that each waypoint is focused on a POI and when you use Virtual Litchi Mission everything looks as you would expect, but, when you actually fly the mission, the camera points straight down (-90 degrees) for the entire mission instead of straight ahead (0 degrees). Is that correct?

This is not normal behavior. If you are using “Focus POI”, you should see gimbal pitch angles of something between 0 and -90 (around -20 would be common). It would really help is if you were to share your mission (uncheck the “Private” checkbox in the “Open” dialog then copy and paste URL here). Without seeing how you have the mission set up, all we can do is guess.

1 Like

Mission Hub - Litchi (

It says I can not post link to that host

Your URL did come through and I have had a look at your mission. I do not see anything wrong with your mission that would cause the behavior you describe.

Have you successfully flown other missions where the gimbal pitch angle behaved as expected? I’m curious if your other missions worked properly which would suggest there is something unique about this mission.

This may require some troubleshooting on your part. Perhaps you could remove all of the camera actions and just fly the mission to see if there is any change in behavior. If you find that changing something results in proper results, please let us know.

1 Like

I have taken the mission you shared and moved it to my location. I then flew your mission using an Air 2s from an IOS device. Your mission was executed with the gimbal pitch angle behaving correctly according to your mission parameters. Since the flight worked properly for me, there must be something unique with your system that is causing the peculiar behavior. Is it possible that you had DJI Fly running in the background while flying this mission? You need to force-close DJI Fly when using Litchi.

Even though the flight heading and gimbal pitch angles worked as expected, some of your camera actions did not. My recommendation is to adjust the camera actions between the first and last waypoints to be:

  1. Stop recording
  2. Wait 1 second
  3. Take photo
  4. Wait 1 second
  5. Start recording
1 Like

It will not stay in Ya Follow changes back to Free (inspire)

That’s because your drone is not connected.
This setting is stored in the drone itself, not in the Litchi app.

1 Like

Thank you.
I found that the firmware was not updating. Found a WIFI connection that worked and my problem was gone.


Good to hear it is sorted, always worth checking firmware is up to date properly