Gimbal yaw problem in Android app

This is my second post about this issue. I have some more data now so maybe Litchi support will show some sign of life.
Flying a Mavic 2 Pro
On waypoint missions with a focus on POI, the gimbal yaws several degrees to the side. Usually it’s to the left, but not always. I went out and ran some tests and got these results:

  • The error seems to occur right when the mission starts. If I recenter the gimbal right after the mission starts, it will correctly point to the POI for the rest of the run.
  • The problem only occurs in the Android app. I replicated the issue with 2 different Android devices, a Lenovo tablet and a Samsung phone, each running 4.25.0-g.
  • I ran the same mission with an iPad running iOS Litchi 2.14.2 and it worked fine, no issues.
  • The drone is running firmware version v01.00.0770

The gimbal yaw problem occurred on:
Lenovo TB-X606F running Android 10 (the latest available OS for that device)
Samsung S21 Ultra SM-G998U running Android 12
The problem did not occur on iPad Air 2 running iOS15.6.1

I created a video that shows the problem- on the left is the VLM file in Google Earth, on the right is footage from the actual flight. The POI is the set of bleachers in the center of the VLM. You can tell the the yaw of the aircraft is pointed toward the POI, but the gimbal is pointed to the left. You can barely see the bleachers on the right edge of the screen. You can see the video here.
The Litchi mission is here.

This is apparently a problem with the Android app. It started happening a few months ago, I’m really not sure exactly when. The last M2P firmware update was in April, 2021. This problem began long after that, so it appears to be related to an Android app update and not a firmware update.