Gimbal stability problems during a mission (AIR 2S)

In all modes other than fpv, your drone is constantly receiving and sending signals to your phone, resulting in delays in the communication channel.

Any waypoint mission using a DJI Fly drone will have less than perfectly smooth yaw movements. This has been reported many times. However, I have never seen results as bad as the ones you have shown. I too have a DJI Air 2s. While my waypoint missions do not result in movements as drastic as you have shown, they aren’t as good as can be done with a Mavic 2 or older drone.

I have heard of some having limited success in smoothing out the yaw jerkyness by making some gimbal adjustments in DJI Fly. In DJI Fly, access the main menu and select “Control” then “Advanced Gimbal Settings”. Under “Normal Mode”, change the Yaw Speed from the default of 75 to something smaller like 35. Also change the default Yaw Smoothness from the default 7 to something like 70. These changes are saved to the drone and will affect flights with Litchi as well. I have tested this and I think I see an improvement in waypoint missions but I’m not 100% convinced.

You may also consider slowing your cruising speed to see if that lessens the erratic movements.

Thank you, Wesbarris.
I will try these new settings. These very bad results concern mainly this particular mission but as you say, they are commonly far from perfect (a friend of mine asked me recently whether I had flown an other mission manually or not). That’s a pity because I was aware about these problems and I waited they were fixed before to buy this new drone. Apparently, this is not still the case. Does Litchi say something about this ? I asked their support, no answer yet…
I could fix partly the jerky yaw you saw in the video above thanks to Premiere Pro. But the framing I did patiently with VLM is changed by the cropp induced by stabilization.

A small piece of Blu- tack will fix the problem for now.

You can take it off when the software is updated.

I did see a message from one of the Litchi staff members about this. He said that they are aware of the problem and are working on it. I also saw a message from one of the beta testers stating that the beta version showed improvements.

Both of these messages were about three months ago. I have not heard anything official since then.

I am a Beta-tester (since 5 years) and I’d like to see an improvement :slight_smile:
Anyway, thanks a lot.

All solutions for today are to make the distance smaller and set the drone speed to low

Unfortunately I believe that Litchi is at the end of the line with the latest (disgusting) ideas of DJI. I am particularly pissed off because I have 3 licenses of Litchi and I am afraid I will not be able to use them anymore. I’m not interested in 3/400 meter missions.

1 Like

Then share which application is better

You rushed. The last one on the list will be the dji mission app.n :slight_smile:

I’ve had an Air 2S for 18 months now and I’ve never seen anything this bad using either Litchi or Dronelink. I’ve uploaded a video of mine from 21 August 2022 to YouTube so you can see how Litchi has worked for me. It has not been stabilised. You’ll see the occasional stutter that may be a Litchi limitation or birds flying too close. According to the Airdate log, the wind speed was 2.2 m/s (5 mph).

Here’s the YouTube link: Litchi waypoint mission 21st Aug 2022 - YouTube

Here’s the Airdata log link: Aug 21st, 2022 08:08AM | General / Overview | Litchi log 4.26.0b | Australia | Airdata UAV

Here’s the Litchi mission: Mission Hub - Litchi

I’ve also modified some DJI Fly settings that affect flight smoothness,
as shown in this video: Litchi and Dronelink settings I use for smooth waypoint missions - YouTube

If you haven’t resolved this yet, here’s a suggestion:

Do some controlled flights in a safe field near you. Create a simple waypoint mission with just three waypoints similar to the choppy section of your problem mission. Fly the simple mission in both light and windy conditions to see if you can recreate the problem. Then try various DJI Fly settings related to smoothness to find the best ones for you.

Don’t settle for what you see in your video.

Good luck.

2 Likes

Thank you Greg. I think that this particular mission was affected by the numerous gusts falling down the hill. Wind was very moderate but with gusts of about the double in speed and with no fixed direction.
I’ll try your settings as soon as I can and I’ll let you know the result.
But my initial remark is still valid : I realized several Litchi mission ressembling this one with my Mavic Pro 1st gen. (with native waypoints in GO4) and I never get a result this bad.

changed the reply ! :sweat_smile:

I think his point was that video from an Air 2s mission can be quite good. He pointed out Fly settings that improved the flight characteristics.

Oh dear … I thought that Greg-Hill was complaining about his video quality !