Gimbal mode stuck at "Free(Inspire)" -- Litchi w/Mini2

Litchi with DJI Mini2, Android 6.0 (Samsung S7)

In Settings–>Aircraft–>Gimbal Mode

I tried changing the setting to “Yaw Follow” or “FPV” but it keeps reverting to “Free(Inspire).”

Is this a problem, or should i just let it go? I thought “Inspire” was a model of drone.

Mostly my missions are okay, with too much jerkiness – i’m reading a lot of posts on that, so i understand the jerkiness is not going to go away right away. But 2 out of 3 missions
have been okay except for that.

However, one mission today, the gimbal was jerking around like crazy, out of control,
so i stopped the mission while the drone was still nearby. I then tried to use the joysticks to return to home, to no avail. The RTH button did work however, so i was fine. Later in the day a new mission went okay. … I don’t know if this is related to the “Free(Inspire)” issue. If it’s not, please ignore this paragraph.

So basically: is it supposed to be stuck in Gimbal Mode “Free(Inspire)”?

I tried this both with just the app (no controller), then with the controller and the drone operating, and got the same result.

Thanks for comments.


Gimbal Mode is a setting stored in the drone itself.
When the drone is not connected to the remote and/or the remote is not connected to the phone, litchi can’t read the current setting from the drone and displays the default ‘Free(Inspire)’. This also means that if you change this setting, Litchi can’t write it to the drone.

The fact that Litchi shows that Gimbal Mode is set to ‘Free(Inspire)’ while the drone is not an Inspire, proves there’s no connection to the drone.

If the Connected drone is Not an Inspire, and you choose ‘Free’, it will be ignored.


It happended the same thing to me and the drone and controller where connected. I was operationg the drove with the controller, but when you change to any other Gimbal mode it returns to Free (inspire).
My gimbal is stuck when flying. I am affraid this is the issue. When it starts all axis moves (normally as it should)
How do I change it?

@Eduardo_Inglez, if you were actually connected to the drone, the Litchi app would have recognized the drone and displayed your drone instead of the default “Free(Inspire)” as is mentioned in the above post by Tribar.